Skip to Content
avatar image
Former Member

JSPM and J2EE Engine problem. J2EE Engine will not start

All,

OS: HP-UX 11.31

SAP BI 7 (NW 7)

I'm having huge problems trying to get JSPM running to apply a support stack to NW 7. Now I've noticed that when in transaction SCICM (> Goto > HTTP Server) I can see that the J2EE Engine is not running.

The dev_jcontrol files is attached:

---------------------------------------------------
trc file: "/usr/sap/BID/DVEBMGS50/work/dev_jcontrol", trc level: 1, release: "700"
---------------------------------------------------
node name   : jcontrol
pid         : 6650
system name : BID
system nr.  : 50
started at  : Fri Apr 25 08:20:24 2008
arguments	  :
	  arg[00] : jcontrol
	  arg[01] : pf=/usr/sap/BID/SYS/profile/BID_DVEBMGS50_I405UXVP03
	  arg[02] : -DSAPSTART=1
	  arg[03] : -DCONNECT_PORT=60184
	  arg[04] : -DSAPSYSTEM=50
	  arg[05] : -DSAPSYSTEMNAME=BID
	  arg[06] : -DSAPMYNAME=I405UXVP03_BID_50
	  arg[07] : -DSAPPROFILE=/usr/sap/BID/SYS/profile/BID_DVEBMGS50_I405UXVP03
	  arg[08] : -DFRFC_FALLBACK=ON
	  arg[09] : -DFRFC_FALLBACK_HOST=localhost


[Thr  1] Fri Apr 25 08:20:24 2008
[Thr  1] *** WARNING => INFO: Unknown property [instance.box.number=BIDDVEBMGS50I405UXVP03] [jstartxx_mt. 840]
[Thr  1] *** WARNING => INFO: Unknown property [instance.en.host=I405UXVP03] [jstartxx_mt. 840]
[Thr  1] *** WARNING => INFO: Unknown property [instance.en.port=3951] [jstartxx_mt. 840]
[Thr  1] *** WARNING => INFO: Unknown property [instance.system.id=50] [jstartxx_mt. 840]

**********************************************************************
JStartupReadInstanceProperties: read instance properties [/usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties:/usr/sap/BID/DVEBMGS50/SDM/program/config/sdm_jstartup.properties]
-> ms host    : I405UXVP03
-> ms port    : 3951
-> OS libs    : /usr/sap/BID/DVEBMGS50/j2ee/os_libs
-> Admin URL  : 
-> run mode   : NORMAL
-> run action : NONE
-> enabled    : yes
**********************************************************************


**********************************************************************
Used property files
-> files [00] : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> files [01] : /usr/sap/BID/DVEBMGS50/SDM/program/config/sdm_jstartup.properties
**********************************************************************

**********************************************************************
Instance properties
-> ms host    : I405UXVP03
-> ms port    : 3951
-> os libs    : /usr/sap/BID/DVEBMGS50/j2ee/os_libs
-> admin URL  : 
-> run mode   : NORMAL
-> run action : NONE
-> enabled    : yes
**********************************************************************

**********************************************************************
Bootstrap nodes
-> [00] bootstrap            : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [01] bootstrap_ID50176400 : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [02] bootstrap_ID50176405 : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [03] bootstrap_ID50176405 : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [04] bootstrap_ID50176405 : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [05] bootstrap_ID50176405 : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [06] bootstrap_ID50176405 : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [07] bootstrap_ID50176405 : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
**********************************************************************

**********************************************************************
Worker nodes
-> [00] ID501764000          : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [01] ID501764050          : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [02] ID501764051          : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [03] ID501764052          : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [04] ID501764053          : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [05] ID501764054          : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [06] ID501764055          : /usr/sap/BID/DVEBMGS50/j2ee/cluster/instance.properties
-> [07] sdm                  : /usr/sap/BID/DVEBMGS50/SDM/program/config/sdm_jstartup.properties
**********************************************************************

[Thr  1] SigISetDefaultAction : default handling for signal 18
[Thr  1] JControlExecuteBootstrap: execute bootstrap process [bootstrap]
[Thr  2] JControlDPMessageProxy: Thread 2 started as handler thread for R/3 dispatcher messages.
[Thr  1] [Node: bootstrap] java home is set by profile parameter
	Java Home: /opt/java1.4
[Thr  1] [Node: bootstrap] java vm type is set by profile parameter
	Java VM Type: server #Added manually J Neilan. 24th April 2008

[Thr  1] Fri Apr 25 08:20:25 2008
[Thr  1] *** WARNING => Can't open output file [./JdkDetection_6650.txt] [jstartxxi_mt 1055]
[Thr  1] *** ERROR => vm detection failed, please have a look the files [jstartxxi_mt 1181]
- java command [/opt/java1.4/bin/java -server #Added manually J Neilan. 24th April 2008 -d64 -cp . JdkDetection_6650 > ./JdkDetection_6650.txt 2>&1]
- output file  [./JdkDetection_6650.txt]
- java file    [./JdkDetection_6650.java]
- class file   [JdkDetection_6650]
- used vm type [-server #Added manually J Neilan. 24th April 2008]
[Thr  1] **********************************************************************
*** ERROR => JDK Detection failed.
*** Please see SAP Note 943602 , section 'JDK detection issues'
*** for additional information and trouble shooting.
**********************************************************************
[Thr  1] *** ERROR => node [bootstrap] not found [jstartxx_mt. 1593]
[Thr  1] JControlExecuteBootstrap: error executing bootstrap node [bootstrap] (rc = -18)
[Thr  1] JControlCloseProgram: started (exitcode = -18)
[Thr  1] JControlCloseProgram: good bye... (exitcode = -18)

I did not install the system and am not sure if the J2EE engine ever worked. The JRE and JDK versions seem to correct. They are:

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2.17-071106-02:40)

Java HotSpot(TOM) Server VM (build 1.4.2 1.4.2.17-071106-08:12-IA64N IA64, mixed mode)

Other "work" dir file notes:

WOrk files notes----


dev_server0.b00

[Thr 1] JStartupICheckFrameworkPackage: can't find framework package

/usr/sap/BID/DVEBMGS50/exe/jvmx.jar

JNOTE: There certainly isn't a jvmx.jar file there.....

[Thr 21] * LOCATION CPIC (TCP/IP) on local host with Unicode

[Thr 21] * ERROR partner 'localhost:sapgw50' not reached

log_bootstrap_ID505436050.0.log

[Apr 17, 2008 7:19:14 PM ] No local properties available for [ApplicationThreadManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [LicensingManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [ClassLoaderManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [PoolManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [LogManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [CacheManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [IpVerificationManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [kernel_shell_commands].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [ThreadManager].

[Apr 17, 2008 7:19:14 PM ] No local properties available for [LockingManager].

I cannot seem to get JSPM working at all. The JAVA_HOME and DISPLAY env vars are correctly set and the instance.properties seems(!) to be right.

Has anyone had trouble getting the J2EE engine working and has anyone got these problems with JSPM?

When I actually try and run the "go" file to run JSPM I get bootstrap errors as follow:

Execution failed: Could not execute bootstrapping. See previous messages.

.....

Could not save namespace BOOTSTRAP to file /usr/sap/BID/DVEBMGS50/j2ee/JSPM/config/./BOOTSTRAP.xml

Input output exception has occurred usr/sap/BID/DVEBMGS50/j2ee/JSPM/config/./BOOTSTRAP.xml (Permission denied (errno:13))

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Apr 25, 2008 at 12:01 PM

    Hai,

    Check by restarting the server,whether both ABAP and JAVA is starting or not.

    You can check the JAVA process by using the jcmon.

    jcmon pf=/usr/sap/<SID>/sys/profile/<SAPSID>_<INSTANCE_ID>_<HOST>.

    useful link

    http://help.sap.com/saphelp_nw70/helpdata/EN/d3/4d074147c1f06fe10000000a1550b0/frameset.htm

    [Thr 1] **********************************************************************

    • ERROR => JDK Detection failed.

    • Please see SAP Note 943602 , section 'JDK detection issues'

    • for additional information and trouble shooting.

    **********************************************************************

    ->

    Also check whether the JAVA is working or not. Or else increase the JDK version.

    Are you able to login into Visual Administrator and Configtool. Also SDM

    Thanks and Regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Solved.

      For those who may stumble on to this thread with the same problem I needed to do the following:

      1) Use SAP note 1013976 to run the remotegui for JSPM, rather then trying to use an unsupported xclient

      2) Change the memory settings of the J2EE engine using /usr/sap/<SID>/DVEBMGS$$/j2ee/configtool/configtool.sh

      There are several notes on this. See 710146, 723909, 736557

      Make sure that the New heap sizes are never bigger than the Max (doh) and that the -Xmx and top level Max match.

      Then use jcmon to monitor it coming up (you can bring it up and down from GUI transaction SMICM)

      You should be able to see it comign up and then you can run JSPM.

  • avatar image
    Former Member
    Apr 25, 2008 at 12:30 PM

    The JDK version 1.4.2.17 is ok.

    Is the JAVA_HOME set ?

    At os level try to - > cd $JAVA_HOME

    or

    check your .profile in root

    JAVA_HOME=/opt/java1.4; export JAVA_HOME

    PATH=$:/opt/java1.4/bin; export PATH

    Did you ugrade the JDK from any previous version, if so

    rename instance.properties.vmprop to instance.properties.vmprop.old (eg) and try to restart the

    pls paste dev_dispatcher

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 28, 2008 at 05:27 PM

    Solved it myself thankfully!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Sapinst stopped at step 35 (or 36) - "Start Java engine"

      jcontrol would not start and dev_jcontrol shows this error message - "JdkDetection_nnnn.class not found"

      Our environment:

      Windows 2003

      Oracle 10.2.0.4

      Solution Manager 7.01 EhP1 SR3

      JDK - 1.4.2_24 rev-b06

      JAVA_HOME=D:\java\j2sdk1.4.2_24

      ORACLE_HOME=D:\oracle\SID\102

      SAPEXE=D:\usr\sap\SID\SYS\exe\uc\NTAMD64

      checked SAP notes:

      943602 Analysis of errors within the startup of J2EE Engine 7.0

      940893 Analysis of errors within the startup of J2EE Engine 6.40

      718901 How to change the JDK of the J2EE Engine

      817991 Startup Framework fails when starting a JLaunch process

      741289 Profile parameters of the J2EE Engine are lost

      943498 J2EE Engine does not start 6.40 and 7.0

      There were some solutions that suggested giving "ALL" permissions to the SIDADM and SAPServiceSID users to the disk drives that we are installing the software on - we did that as well, but it did not help us. Java engine won't just start. jcontrol would just die with the same error.

      After spending enormous number of hours sifting through very few documents found on this error - I got fed up and here is what I did when I got the "JdkDetection_nnnn.class not found" error:

      1. Logged in to the server as SIDADM

      2. Opened a windows command prompt

      3. ran this command -- jcontrol pf=D:\usr\sap\SID\SYS\profile\SID_DVEBMGS00_hostname

      4. waited for 15mins

      5. Restarted sapinst

      6. Continued successfully

      I am thinking that jcontrol was having a difficult time to start for the first time at Step 35 (or 36) during sapinst. When I started it on the command line with just the profile as the parameter - it pulled in all the required configuration from the database and started the dispatcher and server successfully. After that - installation went on smoothly.

      Hope this helps.

      Sri