Skip to Content

[BUG] Unable to change primary tag for the question

Jan 05 at 11:15 AM


avatar image

Test case:

1. Edit any question with only primary tag

2. Delete existing primary tag

3. Type: "EPM" or "EPM Add-In for Excel"

4. No result:

Just for test, I am able to create new question with a primary tag: EPM Add-In for Excel

P.S. Attn.: Mynyna Chau

epmtag.png (17.0 kB)
10 |10000 characters needed characters left characters exceeded

Hi Vadim,

Me and another colleague (thank you Sajid Amir) have failed to recreate this. Is there any additional information you can provide - e.g. browser type?

Maybe Sebastian Wolf can ask for additional information.



The bug is also confirmed by Veselina Peykova.

* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Sebastian Wolf
Feb 15 at 10:17 AM

Dear Vadim Kalinin,

thanks again for reporting this bug. It is fixed now, please retest.

Best regards, Sebastian

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Just tested. The bug is corrected. Thanks!

Vadim Kalinin Jan 05 at 11:31 AM

P.S. Tested the same with another tags - same story, tag selection in the edit question is broken!

10 |10000 characters needed characters left characters exceeded
Vadim Kalinin Jan 05 at 05:06 PM

Hi Brian (Brian Bernard)!

I am using Firefox:

I will test on this particular question: attempt to change primary tag from "Using" to "EPM Add-In for Excel"

Edit question:

Delete primary tag:


Typing "EPM":

Not able to select the correct tag!

tagch0.png (169.5 kB)
tagch1.png (157.7 kB)
tagch2.png (46.4 kB)
tagch3.png (28.7 kB)
tagch4.png (19.6 kB)
Show 7 Share
10 |10000 characters needed characters left characters exceeded

Hi Veselina Peykova !

Can you test the same?


I get the same results as you - I can select the EPM tag only as secondary in existing questions, I could not find it by typing other criteria as well .

And why on earth I get Ariba Cloud Integration and ABAP Development in the search result when I type Excel is a mystery...

In addition to the ESR version I tested in Firefox 58.0b14, Pale Moon 27.6.2 and Google Chrome 63.0.3239.84 and TOR 7.0.11, although this is unlikely to be related to a specific browser version or browser settings/add-ons, country etc. In my case I am fairly sure that this is not related to caching on my end.

I noticed that in general the search on primary tag when you wish to change it for an existing question does not work correctly also for other very common and known tags like SD Sales and Distribution, MM Materials Management, but works correctly if you type exactly the same in a secondary tag field.

Since this works for the support team (assuming clearing cached data before testing), but not for us, this might be related to a specific network (we are not SAP employees) or authorizations (none of us is a moderator).

drop-down.jpg (28.4 kB)

"none of us is a moderator" - that was the reason I asked you to confirm! Thanks!


P.S. This bug was found by another user - when I asked him to correct the primary tag of his question, he told me that he is unable to do it.


This is very strange. I was able to change the tag of this question (to EPM Add-In for Excel) and save it with no problem. At this point, I suggest we wait for the mastermind behind the tag picker (aka Sebastian Wolf) to return from vacation and take a look at this.

P.S. I tried in Firefox as well.


Sorry, but to perform a correct test you have to:

1. Create a test Community user (P-ID) without moderator privileges (if you don't have it already)

2. Login with this P-ID

3. Create a test question with some primary tag.

4. Edit this question and try to change primary tag.

"I was able to change the tag of this question" - this is not a correct test case!

P.S. I suspect that Sajid Amir tested also using his account!


Hi Vadim Kalinin , Veselina Peykova ,

thanks for reporting and for the detailed steps to reproduce. The issue is clearly reproducible and we will fix that!

Best regards, Sebastian