Skip to Content

BW on HANA 7.4 -> BW on HANA 7.5

Jan 09 at 02:19 PM


avatar image

Hi Experts,

we are actually at BW on HANA 7.4 and we would like to move to BW on HANA 7.5 (Not BW/4HANA, because we have still in use a lot of 3.x Datasources.) We are planning to do this in SANDBOX first.

My question is:

Could you please suggest any possible action, check, tasks, risk (in relation to the actual 3.x Datasources and ODP vs SAPI Framework) that we should definitely pay attention to before/after doing the Migration?

Can we still use the SAPI framework or we should use the ODP Framework in BW on HANA 7.5. Also does the ODP Framework support the 3.x Datasources?

Thank you in Advnace,


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Roland Kramer
Jan 29 at 02:01 PM

If you are not planning to move to HANA, there is no need to upgrade to 7.50 at all
The latest Features for non HANA were delivered for 7.31 except the long InfoObject Names in 7.40

See the Presentation Upgrade to SAP BW 7.50


Best Regards Roland

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hallo Roland,

thank you very much for finding time to respond to my answer. We are actually on BW on HANA 7.4 and we want to upgrade our SAP Netweaver to 7.5 (BW on HANA 7.5 SP10). Because we are using some of 3.x Dataflows, I was just wondering if some issues may arise by the migration?

Until now, I know that we don't want to install the BW4/HANA Starter Addon because that would put our system in compatability mode and then we may have difficulties with creating/managing 3.x Objects.

Thank you in advance.

Best Regards,



Actually the Installation of the Starter Add-On has an option which is like the System State without the Add-On

See the Blog – On the Road to BW/4HANA – first stage accomplishedsecond stage finalizedchoose your Path

Best Regards Roland