Skip to Content
0
Former Member
Jan 08, 2018 at 02:51 PM

SAP GUI 7.50 remote installation LSH problem on Windows 10

2659 Views Last edit Jan 09, 2018 at 05:51 AM 2 rev

Hello SAP community, I need help with installation service NwSapSetupDs. I have configure of server in domain and two clients. The first client isWindows 10 and second Windows 7. The problem is strange. Everything works well on Windows 7. But on the Windows 10 build 1709 machine I always getting error message about rights - NwSetup was not able to grant you administrator rights. I read lot of forums and notes (for example 593486,help..)But now I don't know what to do.

Instalation on Windows 10 is OK when I run NwSapSetup.exe under administrator account or when I tryed run remote instalation from server. There is no problem.

Under user account this is not working

Thank you for your help

OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

When I run command on Workstation Windows 10

********************************************************************************

\\brn-sapupd-01\SAPUPDSRV\Setup\NwSapSetup.exe /nodlg /Package="SAPINSTALL" /once:"OnceInstTagXY" :

NwSapSetup was not able to grant you administratort rights, either because

- the distribution service didn't respond,

- the installation service couldn't be started or

- the logon credentials for the installation servuce are incorrect

Please contact your system administrator.

OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

Log fileNwSapSetupIS from Windows workstation Windows 10

********************************************************************************

Logfile: C:\Program Files (x86)\SAP\SapSetup\LOGs\NwSapSetupIs.log

Started logging: Mon Jan 08 13:59:30 2018 (Støední Evropa (bìžný èas))

Operating system: Windows 8 Professional (Build 9200)

Executing user: Administrator (Administrator)

Workstation name: LAB-KLIENT

Windows directory: C:\WINDOWS

Temp directory: C:\Users\ADMINI~1.LAB\AppData\Local\Temp

Working directory: C:\WINDOWS\system32

Commandline: '\\BRN-SAPUPD-01.LAB.local\SAPUPDSRV\Setup\NwSapSetupIs.exe'

Executable: '\\BRN-SAPUPD-01.LAB.local\SAPUPDSRV\Setup\NwSapSetupIs.exe'

Version: 9.0.85.0

ProcessId: 828

ThreadId: 6224

Physical memory: 2636 MB of 4096 MB free

System Uptime: 1 day, 2:48:31 hours

System libraries information

----------------------------

atl.dll:3.5.2284.0

comctl32.dll:5.82.16299.192

vbscript.dll:5.0.0.3715

msvcrt.dll:7.0.16299.125

oleaut32.dll:6.2.16299.15

shell32.dll:6.2.16299.192

shlwapi.dll:6.2.16299.15

msi.dll:5.0.16299.15

SAPSetup libraries information

-------------------------------

NwSapSetupEngine.dll:9.0.85.0

NwSapSetupATLCommon.dll:9.0.85.0

NwSapSetupUi.dll:9.0.85.0

NwSapFeiUt.dll:9.0.85.0

NwSapFeiLg.dll:9.0.85.0

********************************************************************************

13:59:31.431 NwSapFeiIs2Installer Service exit code Error message: Access Denied. Error code 0x00000005 (5).

OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

Log fileNwSapSetup from Windows workstation Windows 10

********************************************************************************

Logfile: C:\Users\MICHAL~1.LAB\AppData\Local\Temp\NwSapSetup.log

Started logging: Mon Jan 08 13:59:29 2018 (Støední Evropa (bìžný èas))

Operating system: Windows 10 Professional (Build 16299)

Executing user: michal.holas

Workstation name: LAB-KLIENT

Windows directory: C:\WINDOWS

Temp directory: C:\Users\MICHAL~1.LAB\AppData\Local\Temp

Working directory: \\brn-sapupd-01\SAPUPDSRV\Setup

Commandline: '"\\brn-sapupd-01\SAPUPDSRV\Setup\NwSapSetup.exe" /nodlg /Package="SAPINSTALL" /once:"OnceInstTag8"'

Executable: '\\brn-sapupd-01\SAPUPDSRV\Setup\NwSapSetup.exe'

Version: 9.0.85.0

ProcessId: 6548

ThreadId: 2128

Physical memory: 2656 MB of 4096 MB free

System Uptime: 1 day, 2:48:30 hours

System libraries information

----------------------------

atl.dll:3.5.2284.0

comctl32.dll:5.82.16299.192

vbscript.dll:5.0.0.3715

msvcrt.dll:7.0.16299.125

oleaut32.dll:10.0.16299.15

shell32.dll:10.0.16299.192

shlwapi.dll:10.0.16299.15

msi.dll:5.0.16299.15

SAPSetup libraries information

-------------------------------

NwSapSetupEngine.dll:9.0.85.0

NwSapSetupATLCommon.dll:9.0.85.0

NwSapSetupUi.dll:9.0.85.0

NwSapFeiUt.dll:9.0.85.0

NwSapFeiLg.dll:9.0.85.0

********************************************************************************

13:59:30.009 NwSapFeiUt1Not running on a terminal server host.

13:59:30.228 NwSapSetup1Distribution server expected as brn-sapupd-01

13:59:30.228 NwSapSetup1Going to call pipe "\\brn-sapupd-01\PIPE\_nw_sapfeids_is_pipe_" sending LAB-KLIENT.LAB.local|192.168.100.5 /fs="\\brn-sapupd-01\SAPUPDSRV\Setup" /cmdline='/nodlg /Package=SAPINSTALL /once:OnceInstTag8 /lshAdminMode' /_upid=6548 /winsta="WinSta0" /desktop="Default" /event="Global\IS_NW_SAPSETUP_Sync_Event{A044350D-48C1-4A3D-BDCA-5D6BF75446FA}"

13:59:31.337 NwSapSetup2Environment : Installer Service will run under account 'LAB\Administrator', SID S-1-5-21-1196479260-3960185005-1702393492-500

13:59:31.353 NwSapSetup1Waiting for IS to start up

13:59:31.353 NwSapSetup1IS is READY to (re)start SAPsetup now - IS is waiting for our event

13:59:31.353 NwSapSetup1EVENT will trigger IS to start SAPsetup NOW

13:59:31.353 NwSapSetup1waiting for SapSetup (admin) to become alive

14:00:01.353 NwSapSetup1WSapSetup(admin) did not become alive

14:00:28.853 NwSapSetup1ELOCAL SECURITY HANDLING FAILED

14:00:28.853 NwSapSetup1------------------------------------------------------------

14:00:28.853 NwSapSetup1Return-Code: 5

14:00:28.853 NwSapSetup1------------------------------------------------------------

OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

Log fileNwSapSetupIS from Windows SERVER

********************************************************************************

Logfile: C:\Program Files (x86)\SAP\SapSetup\LOGs\NwSapSetupDs.log

Started logging: Mon Jan 08 14:22:13 2018 (Central Europe Standard Time)

Operating system: Windows Server 2012 Datacenter Edition (Build 9200)

Executing user: Administrator (Administrator)

Workstation name: BRN-SAPUPD-01

Windows directory: C:\Windows

Temp directory: C:\Users\ADMINI~1.LAB\AppData\Local\Temp

Working directory: C:\Windows\system32

Commandline: 'C:\SAPUPDSRV\Setup\DS\NwSapSetupDs.exe'

Executable: 'C:\SAPUPDSRV\Setup\DS\NwSapSetupDs.exe'

Version: 9.0.85.0

ProcessId: 1708

ThreadId: 1348

Physical memory: 3181 MB of 4096 MB free

System Uptime: 0 days, 22:04:34 hours

System libraries information

----------------------------

atl.dll:3.5.2284.0

comctl32.dll:5.82.9200.17359

vbscript.dll:5.8.9200.22008

msvcrt.dll:7.0.9200.16384

oleaut32.dll:6.2.9200.21950

shell32.dll:6.2.9200.17464

shlwapi.dll:6.2.9200.16384

msi.dll:5.0.9200.17412

SAPSetup libraries information

-------------------------------

NwSapSetupEngine.dll:N/A

NwSapSetupATLCommon.dll:N/A

NwSapSetupUi.dll:N/A

NwSapFeiUt.dll:N/A

NwSapFeiLg.dll:N/A

********************************************************************************

14:22:13.890 NwSapFeiDs1WinMain started in Thread 1348

14:22:13.890 NwSapFeiDs1Running as a SERVICE

14:22:13.906 NwSapFeiDs1Service Run has ThreadId 1588

14:22:13.906 NwSapFeiUt1IS-Cred not updated

14:22:13.906 NwSapFeiDs1Going to create named pipe \\.\PIPE\_nw_sapfeids_is_pipe_

14:22:13.906 NwSapFeiUt1Listener pipe created

14:22:13.906 NwSapFeiUt1Listener pipe is waiting for notifications

14:22:20.442 NwSapFeiUt1Server got a connection on the pipe

14:22:20.442 NwSapFeiUt1Pipe read message:

LAB-KLIENT.LAB.local|10.101.110.132|192.168.100.5 /fs="\\brn-sapupd-01\SAPUPDSRV\Setup" /cmdline='/nodlg /Package=SAPINSTALL /once:OnceInstTag8 /lshAdminMode' /_upid=6512 /winsta="WinSta0" /desktop="Default" /event="Global\IS_NW_SAPSETUP_Sync_Event{BDBC378F-E528-4684-A33F-8F0066EA3A60}"

14:22:20.442 NwSapFeiDs1Transmitted string:_ LAB-KLIENT.LAB.local|192.168.100.5 /fs="\\brn-sapupd-01\SAPUPDSRV\Setup" /cmdline='/nodlg /Package=SAPINSTALL /once:OnceInstTag8 /lshAdminMode' /_upid=6512 /winsta="WinSta0" /desktop="Default" /event="Global\IS_NW_SAPSETUP_Sync_Event{BDBC378F-E528-4684-A33F-8F0066EA3A60}"

14:22:20.442 NwSapFeiDs1CRemoteInst is going to start new thread

14:22:20.442 NwSapFeiDs1New thread is running

14:22:20.442 NwSapFeiDs1Going to create named pipe \\.\PIPE\_nw_sapfeids_is_pipe_

14:22:20.442 NwSapFeiUt1Listener pipe created

14:22:20.442 NwSapFeiUt1Listener pipe is waiting for notifications

14:22:20.489 NwSapFeiDs1Service installation (1. try)

14:22:20.520 NwSapFeiUt1Trying to make user 'lab\Administrator' local admin of 'LAB-KLIENT.LAB.local' (group 'Administrators')

14:22:20.552 NwSapFeiUt1User is already an admin on this wksta

14:22:20.552 NwSapFeiUt1Checking remote registry access

14:22:20.567 NwSapFeiUt1Service status is Stopped

14:22:20.567 NwSapFeiUt1remote registry service is stopped... Starting service...

14:22:20.598 NwSapFeiUt1Successfully started service RemoteRegistry

14:22:20.598 NwSapFeiUt1Service status is StartPending

14:22:20.708 NwSapFeiUt1Service status is Running

14:22:20.708 NwSapFeiUt1Successfully waited for service to start up

14:22:20.723 NwSapFeiUt1Security: allowed lab\Administrator to logon as service

14:22:20.739 NwSapFeiUt1Security: allowed lab\Administrator to logon interactively

14:22:20.754 NwSapFeiUt1Security: allowed lab\Administrator to act as part of system

14:22:20.754 NwSapFeiUt1Security: allowed lab\Administrator to replace process-level token

14:22:20.754 NwSapFeiUt1Service status is Stopped

14:22:20.754 NwSapFeiUt1Service status is Stopped

14:22:20.754 NwSapFeiUt1The service is already installed and will be reconfigured

14:22:20.770 NwSapFeiUt1Successfully changed configuration of service NwSAPInstallerSvc.

14:22:21.659 NwSapFeiUt1Successfully started service NwSAPInstallerSvc

14:22:21.675 NwSapFeiUt1Successfully sent message:

lab\Administrator

14:22:21.675 NwSapFeiUt1Service status is Running

-- last line is repeated 7 times --

14:22:21.800 NwSapFeiUt1Service status is Stopped

14:22:21.800 NwSapFeiDs1IS is now stopped.

14:22:21.800 NwSapFeiUt1WCould not determine service status: Error message: Access is denied. Error code 0x00000005 (5).

14:22:21.800 NwSapFeiUt1Successfully stopped service RemoteRegistry

14:22:21.800 NwSapFeiDs1Remote installation with host (address) "LAB-KLIENT.LAB.local" was successful

14:22:21.800 NwSapFeiDs1DONE with remote installation