Skip to Content

Error testing Web Service...

Hi,

I have created new web service ZDEMO_ACCOUNT in web service creation tool. I can see the WSDL page created. Now, when I test the webservice.....I am getting error saying "Error retrieving URL to Web Service test page for Web Service Name Zdemo_account".

Could anyone please tell why I am facing this error.

Regards,

Phani.

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Apr 24, 2008 at 04:43 PM

    Hi,

    you have to activate the service in transaction SICF.

    Search there for the name of your created WebService.

    Make sure that the service is set to active.

    You need to assign User and Password in the service in tabstrip item Logon-data as a requested service can not open an authentication popup.

    In Dev-System you can check with your own user. In Prod make sure to use a dedicated non Dialog user.

    Regards

    Frederic

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Phani,

      which testing environment are you using for your tests ? In the standard NW environment we sometimes phase problems with caching - here it helps to close all (!!!) Internet Explorer windows and then to retry it. In case you are trying to test it with 3rd party tools - have you already tested the service with the SAP Netweaver testing evnironment ? You can find a link to the this testing environment on the Web Service Tool Wizard Page 4 in the left lower corner.

      Best regards, Thilo

      Edited by: Thilo Berndt on May 1, 2008 5:00 AM

  • author's profile photo Former Member
    Former Member
    Posted on Apr 25, 2008 at 01:48 PM

    Hi there,

    I am very much confused about the selection of SAP Module. I did 10+2 2001 in PCM, B.A(Hons)in Geography 2004, PGDCA-2006 through Distance learning and MCA-2008 also through distance learning.I am not good in programing but having interest in database and ERP. I am in job since 2004 and holding more then 3 years of experience in total with HCL-BPO and UnitedHealth Group as an Operations Executive.More then 2 years of my experience is in healthcare insurance industry only.

    I will be very much thankful If anyone can suggest me which Module will be best for me as per my experience and qualifications.

    Thanks and Regards

    Gulfam

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 18, 2009 at 11:21 AM

    i have the same problem. when i run SIRF

    it gives this xml

    - <soap-env:Envelope xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/">
      <soap-env:Header /> 
    - <soap-env:Body>
    - <soap-env:Fault>
      <faultcode>soap-env:Server</faultcode> 
      <faultstring xml:lang="en">SRT: Wrong Content-Type and empty HTTP-Body received</faultstring> 
    - <detail>
    - <ns:SystemFault xmlns:ns="http://www.sap.com/webas/710/soap/runtime/abap/fault/system/">
      <Host>undefined</Host> 
      <Component>COREMSG</Component> 
    - <ChainedException>
      <Exception_Name>CX_SOAP_CORE</Exception_Name> 
      <Exception_Text>SRT: Wrong Content-Type and empty HTTP-Body received</Exception_Text> 
      </ChainedException>
      </ns:SystemFault>
      </detail>
      </soap-env:Fault>
      </soap-env:Body>
      </soap-env:Envelope>
    

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 02, 2009 at 01:48 PM

    We have fixed this issue by setting up a new web service user account with authorization object s_service , the user and password were maintained at the service level by using soamanager --> Business Administration -> Web service administrations -> select the web service --> conifigurations -> edit and maintain userid and password . Check in transaction SICF and it should visible there too ( it will dissappear from the soamanager screens randomly but check SICF if it there or not ).

    When the link for open web service navigator for selected binding is clicked , it should open up the portal internet explorer webs services navigator screen( or which ever java server that is linked in the Technical configuration ---> system global settings --> Access information J2EE server ).

    In the Business administration > overview > click Open WSDL document for selected binding . Copy and paste this link in the web services navigator screen --> WSDL or URL of the web service field . Should ask you for a logon of the end point system and bring up the test browser.

    Good Luck

    Ali.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.