Skip to Content

No SLD elements of type SAP_XIAdapterFramework found

Dear Experts,

I'm working on REST look up scenario referring to this blog.

https://blogs.sap.com/2015/09/11/yes-rest-lookup-is-possible-in-pi/

I'm stuck with one error which I'm not able to resolve.

The error is as below:

  • Errorcom.sap.aii.mapping.lookup.LookupException: Plain exception:Error when calling an adapter by using the communication channel REST_LOOKUP_RECEIVER_CC (Party: , Service: REST_LOOK_UP_BC, Object ID: e061dcd7a5cf36cebade68aafba174de)
    IBaseException:No SLD elements of type SAP_XIAdapterFramework found
    com.sap.aii.ibrun.server.lookup.AeAddressData$AeException: No SLD elements of type SAP_XIAdapterFramework found
    at com.sap.aii.ibrun.server.lookup.AeAddressData.getUrl(AeAddressData.java:138)
    at com.sap.aii.ibrun.server.lookup.AeAddressData.<init>(AeAddressData.java:81)
    at com.sap.aii.ibrun.server.lookup.AdapterAccessHmiClient.<init>(AdapterAccessHmiClient.java:75)
    at com.sap.aii.ibrun.server.lookup.AdapterAccessHmiClient.getInstance(AdapterAccessHmiClient.java:150)
    at com.sap.aii.ibrun.server.lookup.AdapterProxyRemote.<init>(AdapterProxyRemote.java:32)
    at com.sap.aii.ibrun.server.lookup.SystemAccessorInternal.getProxy(SystemAccessorInternal.java:134)
    at com.sap.aii.ibrun.server.lookup.SystemAccessorInternal.<init>(SystemAccessorInternal.java:54)
    at com.sap.aii.ibrun.server.lookup.SystemAccessorHmiServer.getConnection(SystemAccessorHmiServer.java:265)
    at com.sap.aii.ibrun.server.lookup.SystemAccessorHmiServer.process(SystemAccessorHmiServer.java:69)
    at com.sap.aii.utilxi.hmis.server.HmisServiceImpl.invokeMethod(HmisServiceImpl.java:139)
    at com.sap.aii.utilxi.hmis.server.HmisServer.process(HmisServer.java:224)
    at com.sap.aii.utilxi.hmis.web.HmisServletImpl.processRequestByHmiServer(HmisServletImpl.java:371)
    at com.sap.aii.utilxi.hmis.web.HmisServletImpl.processRequestByHmiServer(HmisServletImpl.java:272)
    at com.sap.aii.utilxi.hmis.web.workers.HmisInternalClient.doWork(HmisInternalClient.java:70)
    at com.sap.aii.utilxi.hmis.web.HmisServletImpl.doWork(HmisServletImpl.java:571)
    at com.sap.aii.utilxi.hmis.web.HmisServletImpl.doPost(HmisServletImpl.java:712)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
    at com.sap.engine.services.servlets_jsp.server.runtime.FilterChainImpl.runServlet(FilterChainImpl.java:202)
    at com.sap.engine.services.servlets_jsp.server.runtime.FilterChainImpl.doFilter(FilterChainImpl.java:103)
    at com.sap.engine.services.servlets_jsp.server.servlet.AuthenticationFilter.doFilter(AuthenticationFilter.java:126)
    at com.sap.engine.services.servlets_jsp.server.runtime.FilterChainImpl.doFilter(FilterChainImpl.java:79)
    at com.sap.xsrf.filter.XSRFProtectorFilter.doFilter(XSRFProtectorFilter.java:62)
    at com.sap.engine.services.servlets_jsp.server.runtime.FilterChainImpl.doFilter(FilterChainImpl.java:79)
    at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:441)
    at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:210)
    at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:441)
    at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:430)
    at com.sap.engine.services.servlets_jsp.filters.DSRWebContainerFilter.process(DSRWebContainerFilter.java:38)
    at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:78)
    at com.sap.engine.services.servlets_jsp.filters.ServletSelector.process(ServletSelector.java:81)
    at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:78)

    I tried the below 2 link to troubleshoot on the issue and everything seems to be okay. All services I restarted and everything s registered as said.

    https://blogs.sap.com/2012/04/05/no-sld-elements-of-type-sapxiadapterframework-found/

    https://archive.sap.com/discussions/thread/1572472

    Please suggest if anything from your end.

    Regards,
    Vidhya

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 17 at 01:57 PM

    Hello Vidya,

    Were you able to resolve this issue? what is the solution for this ?

    Regards,

    Sriprasad Shivaram Bhat

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      Usually the problem is incorrect SLD registration (missing associations between the technical systems). It's recommended to rerun the SLD registration wizard to fix the incorrect registration as per SAP Note 2034226 - Configuration Wizard: PI AEX SLD Self Registration.

      Best regards,
      Mate

  • Jan 22 at 12:06 AM

    Hi Vidhya,

    could you please confirm if other channels are working ? try to restart the REST adapter service

    Thanks

    Sugata

    Add comment
    10|10000 characters needed characters exceeded