Skip to Content

Cannot connect to SAP (BW) via Eclipse (SAP GUI works)

Jan 08 at 09:02 AM


avatar image


We are unable to connect to our BW/4HANA system via Eclipse.

Logon via the SAP GUI works fine.

We receive this error message when creating a new BW or ABAP Project:

Failed to load discovery "/sap/bc/adt/core/discovery" for destination XXX_001_xxxxxx_en; using default settings

Does anyone have any initial ideas?

We are connecting via OpenVPN. Could this be causing the problem perhaps?

I can copy/paste the longer Exception Stack Trace if that helps.



10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Armin Beil
Jan 09 at 07:39 AM

Hello Mark,

the message text is not sufficient to identify the reason for the issue. Probably the exception stack trace also would not be sufficient.

You can do the following:

- Create a customer incident for component BC-DWB-AIE
- In eclipse open the view "Communication Log" and press the button "Start logging"
- Try to logon as you did before (causing "Failed to load discovery")
- Choose menu "Help" -> "Collect Support Information"
- On the dialog expand "Additional Data" and check "Communication Log"
- Finish the dialog and the support file export
- Add the file to the customer incident
- (Optional) Stop and clear the communication log

The should rather not be uploaded here in public SCN.

Best regards,

10 |10000 characters needed characters left characters exceeded