Skip to Content
0

Crystal Reports 2016 slow start on Windows 10

Jan 05 at 06:05 PM

417

avatar image
Former Member

I've noticed on all of our Windows 10 installations of CR 2016 are very slow. About 30-40 seconds in some cases. These machines are all i7s with plenty of ram 8g+.

Is there some windows setting that I need to adjust to fix this?

This is very bad for productivity.

10 |10000 characters needed characters left characters exceeded

I can confirm this issue with Crystal 2008 as well. Waiting minutes for CRW32.exe to start.

Until recently (maybe a few months ago) CRW2008 startup was very fast (seconds) - I'm using an i7 with 32GB.

Presumably this became a problem after one of the recent Win10 updates?

Closing / Restarting explorer.exe via task manager seems to solve the problem at least temporarily.

I'm not sure if any one of the explorer settings / changes suggested by Vitaly is a permanent workaround, and also not sure if running explorer in separate processes is desirable.

A permanent fix would be the best solution, whether that comes from Microsoft or SAP.

0
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Vitaly Izmaylov
Jan 23 at 03:26 PM
0

Thank you for the confirmation.

I had the same problem on my machine for few months (had to restart Windows Explorer 1-2 times a day), then one of the OS updates fixed the problem. I did not apply any special fixes, but here is what I found:

https://www.drivereasy.com/knowledge/solved-windows-10-file-explorer-crash-easy-way/

Note, the problem with Windows Explorer caused not only slow start for Crystal Reports, but affected some other applications.

Share
10 |10000 characters needed characters left characters exceeded
Dell Stinnett-Christy Jan 09 at 05:01 PM
0

1. On the Help menu, turn off "Show Start Page". This contains web content that is refreshed every time Crystal is opened.

2. Use the registry setting to turn off "Check for Updates" when Crystal is starting:

The base path for this is:

  • HKEY_LOCAL_MACHINE\ Software \Wow6432Node\SAP BusinessObjects\Suite XI 4.0\ (on 64 bit OS)
  • HKEY_LOCAL_MACHINE\ Software \ SAP BusinessObjects\Suite XI 4.0\ (on 32 bit OS)
  • HKEY_CURRENT_USER\ Software\ SAP BusinessObjects\Suite XI 4.0\

a. In the above paths, go to "\CrystalReports". Find or create the key "DisableCheckForUpdates" and set it to 1.

b. In the above paths, go to "\Crystal Reports\CheckForUpdates". Find or create the key "DisableOnStartUp" and set it to 1.

-Dell

Share
10 |10000 characters needed characters left characters exceeded
Vitaly Izmaylov
Jan 19 at 04:28 PM
0

We found with some users (at least 3 users reported) that the delay in CR 2016 start caused by Windows Explorer process.

Crystal Reports starts normally after windows explorer process restart in Task Manager. If you still have the problem, can you test it?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jan 23 at 03:17 PM
0

My CR 2016 was taking several minutes to load. Yes, minutes. A restart of the windows explorer task fixed the problem. Is this a one time thing or will it continue to occur?

Ozzie

Share
10 |10000 characters needed characters left characters exceeded
Patrick Simons Feb 22 at 09:17 AM
0

We found out that under Windows 10, after uninstalling SP 4 or SP 5, everything is working again as expected.

So there should be a bug above SP 2 somewhere...

Although on another PC running with Windows 8.1, SP 5 is working like a charm.

Regards,

Patrick

Share
10 |10000 characters needed characters left characters exceeded