Skip to Content
avatar image
Former Member

SAP Netweaver Portal compatibility issues with IE 8?

Does anybody have information or possibly another thread where the upcoming IE 8 is discussed in regards to SAP changes? Will SAP need any patches, updated, etc. for the new IE 8 functionality?

When using IE 8, our portal shows errors below, does anyone know what these errors are and whether there are solutions to these?

Thank You!

Message: Object expected

Line: 156

Char: 1

Code: 0

URI: http://.............../irj/servlet/prt/portal/prteventname/Navigate/prtroot/pcd!3aportal_content!2fsunocoNet!2fcom.sunoco.CustomPortalDesktop!2fcom.sunoco.RetailPortalDesktop!2fframeworkPages!2fcom.sunoco.SunocoNetFrameworkPage!2fcom.sap.portal.innerpage?InitialNodeFirstLevel=true&windowId=WID1243886801875

Message: '_htmlbLink' is undefined

Line: 168

Char: 3

Code: 0

URI: http://................./irj/servlet/prt/portal/prteventname/Navigate/prtroot/pcd!3aportal_content!2fsunocoNet!2fcom.sunoco.CustomPortalDesktop!2fcom.sunoco.RetailPortalDesktop!2fframeworkPages!2fcom.sunoco.SunocoNetFrameworkPage!2fcom.sap.portal.innerpage?InitialNodeFirstLevel=true&windowId=WID1243886801875

Message: Object expected

Line: 168

Char: 1

Code: 0

URI: http://....................../irj/servlet/prt/portal/prteventname/Navigate/prtroot/pcd!3aportal_content!2fsunocoNet!2fcom.sunoco.CustomPortalDesktop!2fcom.sunoco.RetailPortalDesktop!2fframeworkPages!2fcom.sunoco.SunocoNetFrameworkPage!2fcom.sap.portal.innerpage?InitialNodeFirstLevel=true&windowId=WID1243886801875

Edited by: Roger Ford on Jun 2, 2009 10:30 PM

Edited by: Roger Ford on Jun 2, 2009 10:34 PM

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Oct 07, 2009 at 09:33 PM

    hi,

    've tested with IE8's compatibility mode?

    greetings

    Manuel

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 08, 2009 at 10:22 AM

    Hi

    Please check the PAM www.service.sap.com/pam to ensure the SAP product you are using

    can be used with IE8

    Thanks

    Stuart

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 12, 2009 at 11:32 AM

    Hi Roger,

    Please tell us which version of EP you are using.

    For NW7.0, find the PAM [here.|http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/30179afb-d90e-2b10-ceb3-d2e441d6407b&overridelayout=true]

    Regards,

    Ami

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 12, 2010 at 12:43 PM

    What is the support package and version of your EP. If not mistaken the SP20 support packs supports IE8 now so you might have to install the latest of the support packs.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 18, 2010 at 01:30 PM

    What NW support package depends on your O/S - for example Windows 7 SP21 is recommended

    Lastly SAP supports product areas on IE8 as indicated in www.service.sap.com/pam - however cannot guarantee

    customer products (on any platform)

    Also although as a general rule of thumb all SAP products that run on the IE8 supported Netweaver platform should work

    and are supported as per the PAM

    - bug fixing is always an ongoing process and although very rare, application teams may still be able to take a decision not to extend support for all or part of a product on certain browsers due to technical reasons

    For IE8 though it has a compatibility mode which makes it run as IE7 therefore you should still be able to use SAP delivered

    products that work on IE7

    Best wishes

    Stuart

    Add comment
    10|10000 characters needed characters exceeded