Skip to Content
0

SAP BPC NW 10.1 / BW 7.5 - False amounts when calling the node "YEAR.TOTAL" of TIME dim. in a report

Jan 03 at 04:14 PM

60

avatar image
Former Member

Hello BPC experts,

I'm facing an unexplainable issue : the amounts of my reports become false when I'm calling a node of TIME dimension "YEAR.TOTAL" in my report.

System informations :

SAP BPC 10.1 NetWeaver

SAP BW 7.5

Model : FINANCIAL / PERIODICAL amounts

Tested perimeter :

2017.01 / ACTUAL / VOLUME / AMOUNT = 964 516

BW screen - Amount is OK

Exemple 1 - Amount is OK - Report on the tested perimeter above with only 2017.01

Exemple 2 - Amount is KO - Exactly the same report than the one above but with 2017.TOTAL and base level

What I tried before posting this message :

1. Tried all MEASURES (PERIODIC / YTD) - Same problem

2. Tried all the possibilities of the report (changing axes, setting all the dimensions, etc., ect.) ---> when the node "2017.TOTAL" is called, the amount of the base level change immediately.

3. Processing the model

4. Processing all dimensions

5. Refreshing the dimensions cache

6. Deleting the data and importing them again

Nothing worked...

Your help will be highly appreciated.

Regards,

Karim

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
avatar image
Former Member Jan 05 at 12:52 PM
0

The problem came from a "corrupted" hierarchy of one of the "user defined" dimensions created.

After removing it, and recreate the last, the problem is resolved.

Regards,

Karim

Show 1 Share
10 |10000 characters needed characters left characters exceeded

What do you mean by "corrupted" hierarchy?

0
Vadim Kalinin Jan 03 at 04:34 PM
0

BW SP please!

TIME dimension screenshot please! (Including nonstandard members if any)

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

BW 7.5 SP 0008

There are no nonstandard members in the dimension.

Here is the TIME dimension screenshot :

Regards,

Karim

0

No bright idea (SP is fresh, no nonstandard members).

Try to reproduce the same on the fresh copy of environmentshell!

0
Vadim Kalinin Jan 03 at 07:20 PM
0

P.S. Try to delete PARENTH1 in Time dimension, save, process, then recreate PARENTH1, save, process.

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

What I did :

1. Clear all datas of the model

2. Delete PARENTH1 > Save and process

3. Recreate PARENTH1 > Save and process

4. Upload the data again.

Now I'm not able to recreate the same error : either I call 2017.TOTAL and base level or 2017.01, I've got the same wrong amount : 962.446 instead 964 .516.

To go further and to scope the problem, I've compared a base level crossing from BW of a determined perimeter with a base level crossing from BPC of the same perimeter :

BPC : Amount = 5.180

BW : Amount = 5.186

The difference between the perimeters compared BPC/BW is the red rectangle above.

What I did : I tried to add manually this missing crossing at the end of to my BPC report by activating the data recognition.

Here the error I got :

"One or more errors occurred.
The execution of report Rapport par défaut failed. Please contact your administrator.
Bad request.

Server message:

code: SY_530
severity: error
description: Exception survenue
log id: 051MctF27jUylz8CxdO0rm
DATAVALUE:
MDX:
V1:
V2:
V3:
V4:

-----------------code: UJO_READ_EXCEPTION_024
severity: error
description: Exception survenue
log id: 051MctF27jUylz8CxdO0rm
DATAVALUE:
MDX:
V1:RC699916
V2:PARENTH1
V3:CLIENT
V4:

-----------------

Framework message:
The remote server returned an error: (400) Bad Request.

The remote server returned an error: (400) Bad Request."

Regards,

Karim

0

Sorry, but I do not understand what are you doing: "I tried to add manually this missing crossing at the end of to my BPC report by activating the data recognition."!

Please show the report with base values amounts - not sure that you are correctly comparing BPC and BW data.

0