Skip to Content
author's profile photo Former Member
Former Member

Configuring MDG Business Partner HANA based Search

generate.jpgerror.jpg

Hi Guys,

I'm Trying to activate the MDG HANA Business partner search(CL_MDG_HDB_SEARCH) on MDG 9.0 system which is on HANA database.

When Trying to generate the Search views , Getting error message

"Unexpected error while activating search view MDG_BS_SUP_SUPPLIER_Reuse"

MDG is on HANA Database only. Hope there's no database connection needed and in Landscape profile no entries i have given.

When i create DB connection and adding that to the Landscape profile settings, the error message in generating search view is different. .

"Some required tables not available in SAP HANA; configure replication"

generate.jpg (29.4 kB)
error.jpg (38.9 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

7 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jan 19, 2018 at 03:24 PM

    Thanks Loga / Senthil and Naga.

    this has been resolved.

    All due to authorization errors in HANA studio.

    REPO.MODIFY_CHANGE

    REPO.MODIFY_OWN_CONTRIBUTION

    • REPO.READ
    • REPO.EDIT_NATIVE_OBJECTS
    • REPO.ACTIVATE_NATIVE_OBJECTS
    • REPO.MAINTAIN_NATIVE_OBJECTS

    These previleges needs to be given to the HANA user id.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 05, 2018 at 04:26 AM

    HI ,

    Is your system on S/4 HANA ? If yes, then this should work automatically no special connections are required .

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2018 at 11:41 AM

    Hi,

    Please go through the below documentation and check if all the settings are in place.

    https://help.sap.com/viewer/fe69af2ae6534e0aa7559a69dd84b7ea/MDG91_SP01/en-US/7293f8516599a060e10000000a44176d.html

    Regards

    Senthil

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 15, 2018 at 12:26 AM

    Hi Senthil,

    I followed the same guide. It's still not successfull.

    @ Venkat

    Yes. As it is on HANA DB there's no DBCO required. This problem is solved. The problem is because of the authorizations in HANA studio. Those have been identified and given and am able to generate the search views.

    But , Even after configuring and generating the search views , the attributes and entities what ever i select is not appearing the search criterias. Only Name1 AND Name2 is appearing.

    Any Pointers on this please.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 16, 2018 at 11:23 AM

    Hello Muthu,

    The fields are not directly displayed in the Search attributes. You will have to enhance the Search UIBB and add the fields which you have added in the Search view, manually. Please find the screenshot on how to identify the correct UIBB that you are using.

    Regards

    Senthil.


    bp-search-uibb.png (83.1 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 19, 2018 at 01:55 PM

    Hi Muthu,

    I never faced the issue but you need to check with Basis about the proper replication to HDB using SLT .

    Before to that you need to identify what function is missing, Debug the class

    CL_MDG_HDB_VIEW_GENERATOR method REPLICATE_TABLES_TO_HDB. Based on your understanding check if you can implement this note 2503673.

    Thanks and Regards,

    Logan.D


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 28, 2020 at 08:54 AM

    This error is described in Note 2835581, and also the solution: “Delete the entry from MDGIMG-> General Setting=>Technical setting for master data=> Define MDG landscape profile and retest the system behavior

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.