Skip to Content

SFTP Duplicate file check not working

HI all,

I have an SFTP to ECC scenario. I am trying to avoid duplicate file processing in the sender SFTP channel. I checked Duplicate File check under processing tab. I also added the parameter "duplicateCheckPersist" under Advanced Tab and entered the value 2160, for 2160 minutes which is 14 days.

I placed a file with the name "TEST-30Nov2017-1234.gpg". It got processed in a minute. I again placed the file, but it was also processed. I restarted the application com.sap.aii.adapter.sftp.app from the NWA and placed the same file and it got processed again!

I checked the SFTP adapter from system info and the details are 1000.1.0.4.18.20160129043500. So it's SP4 and patch 18. It should be ideally supporting this feature.

In the Advanced Tab, I have checked only Set Adapter-Specific Message Attributes and Filename. Directory, Filesize, Timstamp all are unchecked.

Also, the file is deleted after processed and archived in a folder. If it's in error state then it's kept in another folder.

Some other parameters.

SFTP server Timeout (ms) is 30,000.

Poll interval 60 seconds

interval msec for modification check 100 seconds

Any idea why this is not taking care of duplicate processing?

Harish

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jan 09 at 02:38 PM

    Hi Harish,

    Check the below document for duplicate handling:

    NetWeaver PI 7.30 File/FTP Adapter - Duplicate Message Handling Feature

    In your case the last modified time stamp is changing every time you placing the file so the adapter is treating as new file and processing the file.

    Regards,

    Praveen.

    Add comment
    10|10000 characters needed characters exceeded

    • HI Praveen

      It's a multimapping scenario. I now understood why it is not working. It's an SFTP to Idoc scenario and also there are two mappings, both multimappings with 1:n. Dynamic configuration doesn't work on Multimappings and hence the SFTP duplicate check is not working

      Harish

  • Jan 04 at 03:23 PM

    Hi Harish

    Please verify this parameters, check filename, directory, size, host, timestamp, host

    other good idea from this URL

    https://archive.sap.com/discussions/thread/3694522

    Regards

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 09 at 11:23 AM

    what is the version of your SAP PI ?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Harish,

      Was this issue fixed for you?

      I am also facing similar issue with Sender SFTP but we are using Advantco SFTP Adapter. We initially had all the 3 duplicate checks enabled in the channel viz. 1. File Path AND 2. File Modification Time AND 3. File Size.

      But due to some issue with the SFTP itself if file got modified for any reason above check failed and file was processed again.

      To fix this Advantco recommended to just keep the File path as duplicate check- it worked fine and gave 'Duplicate Found: Source File 'abcxyz.txt' is already processed ' error. But not for all the files and one file did get processed again within 2 minutes of file getting processed initially.

      Please suggest how you fixed the issue at your end, i understand you are using SAP SFTP Adapter, i may consider that option as well for my interface.

      Thank You!

      Regards,

      Ashwani