Skip to Content
avatar image
Former Member

BRTOOLS BR0301E SQL error -942 at location BrLicCheck-105, SQL statement;

Hi Everyone,

I get the following error when launching brtools and trying to execute a DB Backup.

=====================================================

BR0301E SQL error -942 at location BrLicCheck-105, SQL statement:

'SELECT COUNT(*), NVL(SUM(BLOCKS), 0) FROM SYS.SEG$ WHERE USER# = 17' ORA-00942: table or view does not exist

=====================================================

I have looked at the following Notes:

134592 - Import of SAPDBA role (sapdba_role.sql)

912969 - BR*Tools fails due to license problems

1598594 - BR*Tools configuration for Oracle installation using user "oracle"

As per note: 134592 i ran the execution as <SID>ADM:

Copied the file from the note on to the working directory on server and executed, results are as follows:

=====================================================

bash-3.2$ sqlplus /nolog @sapdba_role R3

SQL*Plus: Release 11.2.0.3.0 Production on Fri Oct 21 10:38:45 2016

Copyright (c) 1982, 2011, Oracle. All rights reserved.

Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit Production With the Partitioning, OLAP, Data Mining and Real Application Testing options bash-3.2$

=====================================================

As per note: 912969 there are not similarities in the error codes. I however did check to insure everything is in order as per note.

As for note: 1598594, i have set permission as specified. I did not rerun any scripts.

Note sure what else might be causing the issue. If anyone could please guide me to the correct solution. Many Thanks.

J

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 24, 2016 at 09:52 PM

    Did you check file permissions according to 113747?

    Regards,

    Harish Karra

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 25, 2016 at 12:38 AM

    Hi J,

    First we need to identify which db user get -942, please share the brtools log, and let us know which os user is calling brtools.

    Then you need to do following testing:

    log on database via sqlplus using the user brtools use
    grant sysdba to the user <<< "just for testing"
    then
    select count(*) from SYS.SEG$;

    If you still get -942, then it may be caused by dictionary inconsistency, you need to run:

    sqlplus /nolog
    conn /as sysdba
    @catalog.sql

    catalog.sql script is under /rdbms/admin directory

    Please run it when the system does not have heavy workload. Details see SAP note 582427.


    Best regards,
    James



    Add comment
    10|10000 characters needed characters exceeded