Skip to Content
avatar image
Former Member

smartforms

Hi,

I am working on a smartform program.I have added a new field customer po number in the o/p screen.When I check in debugging mode it is showingthe value 'multiple pick' for customer po number field.But in the o/p it is displaying the value as 'transp test'.

Can anyone tell me why I am getting different values?

Regards,

Hema

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Apr 16, 2008 at 01:10 PM

    Hi Hema,

    This can be due to Conversion routine. Go to that table - field which u are displaying, check in its domain

    if Convs Rout. parameter is filled with any value then dbl click this parameter and check the function module CONVERSION_EXIT_*_OUTPUT will be there , then u have to call this FM in ur program , pass input parameter i.e field which u are using to display , by passing this u will get actual value in output parameter which u need to use in ur smartform to display that particular field.

    Regards

    Shweta

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi shweta,

      I have checked in the domian for this field.The conversion routine field is empty.Can you tell me any other solution?

      Regards,

      Hema

  • avatar image
    Former Member
    Apr 16, 2008 at 01:15 PM

    Hi,

    I think u have done passed wrong fieldname in smartform. Check once again,

    Try to debug the smartform. and check that the driver program value is passing to smartform or not.Means try to find the point where the value is getting changed.

    regards

    Sandipan

    Add comment
    10|10000 characters needed characters exceeded