Skip to Content
author's profile photo Former Member
Former Member

MI 7.1: Install new app in the client

Hi, i have an application, i upload the application by the transaction SDOE_UPLOAD_ARCHIVE , all work fine, i assign the application to the device.

I sync my device but not install the application and not appear nothing.

In the manage device appear this app "Installed" but in the device not appear nothing about the app. Why?

Thanks,

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 16, 2008 at 09:25 AM

    Hi,

    I will make it more clear..

    1. In NWDS 7.1 - go to Window - Preferences - Mobile - Laptop - Client - and give path of your Netweaver mobile client installation directory and optionally you can give userid and pwd in User Authentication settings.

    2. Now right click on your application/development component and say Deploy, this will deploy the sda file onto your client and now you also have option to run from NWDS which internally starts the NW Mobile client 7.1

    Regards,

    Siva.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 16, 2008 at 08:15 AM

    Hi,

    Did you check on the client if this applications is installed, I mean you can go to installation directory on the client and check under mobileapps folder if there is any application installed.

    You can even check the trace file and see if there is any error while installing on the client.

    Best Regards,

    Siva.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 16, 2008 at 08:30 AM

    Hi,

    I dint get your question completely. But I would suggest you few options.

    1. Check in that installation directory on the client, if the application deployed on the middleware is properly/completely downloaded to the client with that folder name. SDA file should be extracted as a folder or check if it is present as SDA file.

    2. If it is presend as a SDA file, then restart the client and go to settings, installed applications and see if there is any error.

    3. Check the trace file in installation directory\log\trace.trc file and see if there are any errors.

    or

    Try this option:

    1. From the NWDS 7.1, configure your settings under window - preferences- mobie applications for laptop i guess and configure your installation directory.

    2. Try to deploy the SDA file locally by right clicking on the application and say deploy but before that do step 1 and check if you are getting the application link.

    Best Regards,

    Siva.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 16, 2008 at 08:43 AM

    Hi,

    After looking at the image, it looks like it installed successfully on the client. The only option I would see now as it is anyway installed is try the other option i have specified.

    Deploy the application locally from NWDS and see if you get the application link in the home page.

    Regards,

    Siva.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      I donĀ“t understand the step 2:

      "2. Try to deploy the SDA file locally by right clicking on the application and say deploy but before that do step 1 and check if you are getting the application link."

      Thanks,

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.