Skip to Content
0

Getting A Failed to Retrieve Data Error 42000 When Adding a Field To Design and then Previewing It

Dec 26, 2017 at 09:25 PM

30

avatar image

Hi. I'm new to the community. I recently downloaded a trial version of Crystal Reports 2016. I started a blank report connected to my MYSQL database using ODBC and started bringing in fields. I then proceeded to bring in a 4th field titled "Dept" which contains text strings. I then got a connection dialog wanting me connect again to the database. I typed in my password and it said something to the effect that it failed to connect to database and then it cleared my whole report I was working on. Thankfully I saved the first 3 fields beforehand.

P.S. I AM able to add this field and others using my old XI version of CR......

I have the latest ODBC driver of 5.3 and I installed crystal reports 2016 service pack 12 in the hopes that it might fix this but to no avail.

Your help is really appreciated!

crystal-reports-42000-error-screenshot.jpg

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Tammy Powlas
Dec 26, 2017 at 09:43 PM
0

Joe - a similar question was asked here - see the responses to see if they help: https://archive.sap.com/discussions/thread/1476332

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Tammy:

John is getting a different error code, but I guess I will look into to see what the version of mysql my company has. It's just so weird as I can bring in some fields but not all w/o getting the error and it wiping out my report.....

0