Skip to Content
0

PI is not getting a new field of IDOC

Oct 21, 2016 at 07:14 AM

124

avatar image

In PI 7.4 Dual Stack system, a new field, which has been added in an exciting segment of INVOICE IDoc, is not getting generated in PI's inbound payload. This is an IDoc to JDBC scenario.

We have done all the below process correctly, but it is not helping.

  1. Have re imported the IDoc in ESR and mapped it with the target field (direct mapping).
  2. Have deleted and re imported the meta data in IDX2, and the new field is available in it.
  3. Have done full and partial cache refresh.
  4. Have checked WE02 in ECC system, the new field is available with correct value.
  5. Have checked WE31 in ECC system, the existing segment with new field seems to be in released status.

Please let me know if I'm missing any other point to check.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Raghuraman S Oct 21, 2016 at 07:41 AM
0

Hello Deepak,

Can you check the points mentioned by Bhavesh in the below discussion

https://archive.sap.com/discussions/thread/3913150

Share
10 |10000 characters needed characters left characters exceeded
Praveen Gandepalli Oct 21, 2016 at 09:15 AM
0

Hi Deepak,

Reload the metadata in PI using below program and then resend the new IDOC again from ERP and let me know.

Regards,

Praveen.


Share
10 |10000 characters needed characters left characters exceeded
srikanth reddy d Oct 21, 2016 at 09:26 AM
0

Hi Deepak,

Reload the metadata or Preload in PI IDoc Adapter Monitor: Metadata Monitor .


capture.png (39.6 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Srikanth,

He said his system is dual stack and i think he is using ABAP IDOC.

@Deepak can you confirm are you using IDOC or IDOC_AAE??

Regards,

Praveen.

0