Skip to Content
0

WebIDE: Issue by copiing a Smart Template, UI Adaptation vanish !

Dec 22, 2017 at 11:04 AM

240

avatar image

Hello WebIDE Guys,

When I copy a Smart Template project to another folder by respecting the hierarchy, the UI Adaptation editor vanish for the copied project.

1. Original project :

2. Copied project :

It will be nice to have a solution because, when I want to export to GIT repo I lost features ;)

Kind Regards,

Joseph

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Richard Zhao
Dec 26, 2017 at 05:25 AM
0

Hello, Joseph. I suggest that you should create the same project first and move those files one by one instead of copy the whole project directly thanks.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello,

Thanks for your advice, but I was completely lazy to do a copy file by file :)

So I found another solution, by doing the following steps :

  1. On the folder, rigth click > GIT > Initialize Local repository
  2. Do a first push in locl Git repo
  3. Then rigth click on the folder : Git > Set Remote
  4. Fill the URL and the credential
  5. Merge the local branch to the remote

In that manner my project is managed by Git repo as expected :)

screenshot-18.png (12.6 kB)
0
avatar image
Former Member
Feb 23 at 05:51 AM
2

Hi Joseph,

This is a common problem when we copy the project. Just right click and go to "Project Settings" and there you will find "project Types".

In the Project Types, just select the "UI Adaptation" and it will work.

Thanks,

Sumit

Share
10 |10000 characters needed characters left characters exceeded
Michal Keidar
Jan 02 at 08:48 AM
0

Not sure I understood what you copied exactly, but make sure the .project.json file is copied as well, as it contains the project's type which makes the command visible.

Regards,
Michal.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

I took care of it, and it didn't work at all.

0