Skip to Content
0

SAP Hybrid Application Toolkit 1.29 - Error during setup

Dec 22, 2017 at 08:55 AM

331

avatar image

Hi gurus,

I'm installing hat 1.29 tool but I have this error during Build the companion app step:

cordova version 6.5.0

Any idea?

Thank you

Patrizia

step.png (30.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Best Answer
Daniel Van Leeuwen
Dec 22, 2017 at 02:37 PM
0

Some of the error message is not visible in the screen shot above.

I have had some versioning issues lately with the FileTransfer plugin and cordova-file-plugin in an unrelated cordova app.

The file plugin requires a certain version of the android platform.

For example the plugin.xml from it may say something like

<engine name="cordova-android" version=">=6.3.0" />

My advice would be to check which version of the android platform you are using with the following command.

cordova platforms

Then also look at the plugin.xml files for the file transfer and file plugins.
It may be that one of them has not been installed.
If that is a problem you could specify or manually add an older version of the plugin.

//Version 5.0.0 of the file plugin requires 6.3.0 or newer.
cordova -d plugin add cordova-plugin-file@4.3.3

Regards,

Dan van Leeuwen

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Thank you. I solved with cordova -d plugin add cordova-plugin-file@4.3.3

Regards

Patrizia

0

Hi Patrizia

In which directory did you run the command?

I tried in \SAP_HAT\WebIdeCompanion:

c:\SAP\SAP_HAT_local\WebIdeCompanion>cordova -d plugin add cordova-plugin-file@4.3.3
Error: CordovaError: Current working directory is not a Cordova-based project.
    at Object.cdProjectRoot (C:\Users\dsteinruecken\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\util.js:151:15)
    at C:\Users\dsteinruecken\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\plugin.js:48:40
    at _fulfilled (C:\Users\dsteinruecken\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:787:54)
    at self.promiseDispatch.done (C:\Users\dsteinruecken\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:816:30)
    at Promise.promise.promiseDispatch (C:\Users\dsteinruecken\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:749:13)
    at C:\Users\dsteinruecken\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:810:14
    at flush (C:\Users\dsteinruecken\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:108:17)
    at nextTickCallbackWith0Args (node.js:452:9)
    at process._tickCallback (node.js:381:13)
    at Function.Module.runMain (module.js:431:11)


c:\SAP\SAP_HAT_local\WebIdeCompanion>
<br>

Edit:

Path should be:

C:\SAP\SAP_HAT_local-1.28.2\WebIdeCompanion\companionapp\CompanionApp>

Best regards
Dominik

0
Former Member

I get below message when run the above command as suggested

C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\CompanionApp2219>cordova -d plugin add cordova-plugin-file@4.3.3 No scripts found for hook "before_plugin_add". Calling plugman.fetch on plugin "cordova-plugin-file@4.3.3" Calling plugman.install on plugin "C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\CompanionApp2219\plugins\cordova-plugin-file" for platform "android Installing "cordova-plugin-file" for android Running command: cmd "/s /c "C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\CompanionApp2219\platforms\android\cordova\version.bat"" Command finished with error code 0: cmd /s /c "C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\CompanionApp2219\platforms\android\cordova\version.bat" Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0 Skipping 'cordova-plugin-file' for android Checking for any plugins added to the project that have not been installed in android platform No differences found between plugins added to project and installed in android platform. Continuing... Generating platform-specific config.xml from defaults for android at C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\CompanionApp2219\platforms\android\res\xml\config.xml Merging project's config.xml into platform-specific android config.xml Merging and updating files from [www, platforms\android\platform_www] to platforms\android\assets\www Wrote out android application name "WebIdeCompanion2219" to C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\CompanionApp2219\platforms\android\res\values\strings.xml android-versionCode not found in config.xml. Generating a code based on version in config.xml (1.0.0): 10000 Wrote out Android package name "com.sap.ide.companion2219" to C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\CompanionApp2219\platforms\android\src\com\sap\ide\companion2219\MainActivity.java This app does not have launcher icons defined This app does not have splash screens defined This app does not have additional resource files defined Prepared android project successfully No scripts found for hook "after_plugin_add".

Any other suggestions?

Regards,

Lalit

0
Former Member
Former Member

Try using this path: C:\Development\HAT_1.29.1\WebIdeCompanion\companionapp\plugins

Regards.

0
avatar image
Former Member Feb 20 at 09:45 AM
1

Hi,

This problem is due to latest cordova file plugin which is not compatible to your sap hat created project.

I was also facing same problem. I resolve it with as below:

1) Create a cordova project(cordova create appName).

2) Add cordova file plugin = cordova plugin add cordova-plugin-file@4.3.2

3) Copy cordova file plugin folder(cordova-plugin-file) from plugins in your cordova project.

4) Now at run time when sap hat create cordova project and start adding plugin, before sap hat add cordova file plugin you paste file plugin (4.3.2).

Share
10 |10000 characters needed characters left characters exceeded
Irfan Gokak Dec 22, 2017 at 02:39 PM
0

Hi,

Can you share complete screen shot?

Share
10 |10000 characters needed characters left characters exceeded
Ludo Noens
Dec 22, 2017 at 11:13 PM
0

Another suggestion is to clean the npm cache. Use the command npm cache clean on the CLI and try the installation again.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 26 at 10:18 AM
0

yes ,with hat 1_29_7 version that error was resolved

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 26 at 10:18 AM
0

Hi,

with hat 1_29_7 version that error was resolved

Share
10 |10000 characters needed characters left characters exceeded