Skip to Content
0

'Busy Threads' JMX metric going critical after deploying my application on SCP

Dec 27, 2017 at 08:32 AM

33

avatar image
Former Member

Hi Colleagues,

I have a java application which uses Spring MVC pattern deployed on SAP Cloud Platform. Every endpoint is accessible from the application deployed and everything works fine, but I constantly get that the 'Busy Threads' metric is CRITICAL. The value of the metric is 2 and the 'Details' field in the process monitoring screen shows an exception:

JMX CRITICAL - java.util.concurrent.ExecutionException: ch.syabru.nagios.NagiosJmxPluginException: objectName not found [Catalina:type=ThreadPool,name="http-bio-8041"]

I checked the log files and there are no messages or errors except the below in the 'Other log' file:

2017 12 22 15:56:43#INFO#LJS_OUTPUT#Thread-13##[EL Info]: 2017-12-22 15:56:43.251--ServerSession(692094827)--EclipseLink, version: Eclipse Persistence Services - 2.5.2.v20140319-9ad6abd|

2017 12 22 15:56:43#INFO#LJS_OUTPUT#Thread-13##[EL Info]: 2017-12-22 15:56:43.555--ServerSession(692094827)--file:/usr/sap/ljs/webapps/elastic-access/WEB-INF/lib/cfa-library-1.0-SNAPSHOT.jar_cfa-framework login successful|

2017 12 22 15:56:43#INFO#LJS_OUTPUT#Thread-13##[EL Warning]: 2017-12-22 15:56:43.558--ServerSession(692094827)--Problem while registering MBean: java.lang.NullPointerException: while trying to invoke the method java.lang.Object.getClass() of a null object loaded from local variable 'object'|

I tried re-deploying the same in multiple accounts, tried to stop process and create additional processes, but it was of no help.

This doesn't happen with any other java application deployed on the same account also.

Can you please let me know what might be going wrong here?

Regards,

Suhas R

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
avatar image
Former Member Jan 17 at 02:54 PM
1

Seconding this, it happens with my app if I run it with Java EE7 Web Profile but not with Java EE6.

Share
10 |10000 characters needed characters left characters exceeded