Skip to Content

web ide for SAP HANA cannot connect to git

Dec 26, 2017 at 05:26 AM


avatar image


I am facing the issue of hana xsa web ide not connecting to internal git server even after adding the relevant certificates.

The IDE is giving security certificate error even after all the certificates are present. Same configuration (same git server and same certificates) is working on another HANA installation.

Any suggestions are welcomed.



git-error.png (9.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Tomer Epstein
Dec 26, 2017 at 06:40 AM

Hello Himanshu,

To enable use of git repository you must customize proxy server -

set the JAVA_OPTS environment variable for SAP HANA JVM:

# xs set-env di-core JBP_CONFIG_JAVA_OPTS '[java_opts: "-Dhttps.proxyHost=proxy.HELLO.WORLD.corp -Dhttps.proxyPort=8080 -Dhttp.nonProxyHosts=\\"*.WORLD.corp|localhost||10.*\\""]'

# xs restage di-core

# xs restart di-core

This might help too:

Have a nice day,


Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi tomer,

Have already done that.




● If your developers are using a Git repository, which requires a proxy to be accessed: JBP_CONFIG_JAVA_OPTS: "[java_opts: \"-Dhttp.proxyHost= -Dhttp.proxyPort= -Dhttps.proxyHost= -Dhttps.proxyPort= -Dhttp.nonProxyHosts=''''\"]" For example: Sample Code JBP_CONFIG_JAVA_OPTS: '[java_opts: " -Dhttps.proxyPort=8080 -Dhttps.nonProxyHosts=\\\"host1|host2|host3\\\" -Dhttp.proxyPort=8080 -Dhttp.nonProxyHosts=\\\"host1|host2|host3\\\""]' Note ● If either of the http.proxyHost and https.proxyHost properties are set, define the http.nonProxyHosts property to include both short and fully qualified host names that should not go through a proxy, as in the above example. ● Make sure that the access to localhost is always direct rather than via a proxy.


my current JAVA_OPTS confing is like this : JBP_CONFIG_JAVA_OPTS: [java_opts: "-Dhttps.proxyHost=proxy -Dhttps.proxyPort=8080 -Dhttp.nonProxyHosts=\"|localhost|\""]. So proxy part is all set up. The error I am getting is certificate related (wed ide is able to connect to the server but not able to verify the certificates even when they are uploaded via di-cert-admin-ui).

Can you tell how can we check detailed logs of web ide operations?


Hi Himanshu Gupta ,

From the command line you wrote it seems the followings are wrong:

  • -Dhttps.proxyHost=proxy --> Is 'proxy' the host name ?
  • -Dhttp.nonProxyHosts=\"|localhost|\" --> missing additional \ (i.e. should be \\")

1. Please re-configure JBP_CONFIG_JAVA_OPTS again to enable use of git repository, and pay attention to following characters: ' " \
# xs set-env di-core JBP_CONFIG_JAVA_OPTS '[java_opts: " -Dhttps.proxyPort=8080 -Dhttp.proxyPort=8080 -Dhttp.nonProxyHosts=\\"host1|host2|host3\\""]'

2. You should also upload your git repository certification to Web IDE Admin tool:

3. Finally, you need to run the followings:

  • # xs restage di-core
  • # xs restart di-core


Michal Keidar
Dec 26, 2017 at 06:13 AM

Michal Tall Tomer Epstein Uri Nizan - Can you please assist?

10 |10000 characters needed characters left characters exceeded