Skip to Content
avatar image
Former Member

BPM - IDoc to SOAP problem (Unable to convert sender service)

Hi,

I have a BPM scenario where I'm sending an Idoc from r/3 to XI to SOAP. As part of my scenario I'm sending an acknowledgment (ALEAUD) back to R/3.

I'm getting Unable to convert sender service IP_BPEL_INBOUND_ORDER to an ALE logical system on the Ack back.

So I usually know what to do when I get this, I do the SLD settings on the r/3 service and I'm OK. But in this case, it's asking for those ALE settings on the Integration Process?

I tried adding a logical system on it but now I'm getting the error that this is already used by the r/3 service. So I'm not to sure what to do next???

Rgds,

Yves

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 10, 2008 at 06:59 PM

    Hi,

    You need to do Header mapping in your Receiver Agreement.

    What you need to do is, in you Integration Directory open the Receiver Agreement (where your sender service is PBM). Just check the check box Sender and take the F4 to help to enter the business system.

    Reason: When you try to send data from BPM as a sender then R/3 system does not recognise the BPM name as any logical system and hence you get the error. And thats whay we do the header mapping.

    Regards,

    Sarvesh

    Edited by: Sarvesh Singh on Apr 11, 2008 12:33 AM

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 10, 2008 at 06:03 PM

    hi

    go to ID, double click to BS>service>Adapter Specific Identifiers and check wether the Logical System and Client are right. if not, Notification>Clear SLD delta chache and try again also press change butom before go to BS>service-->Adapter Specific Identifiers.

    next to butom APPLY there is other to compare the data with SLD, press it to refresh data.

    Also check wether the Client in SLD has the proper Logial system Name.

    Another thing > go to receiver agreement (response to R3). In header mapping>sender service select the PI Bussiness system and try again.

    Thanks,

    Rodrigo

    Edited by: Rodrigo Pertierra on Apr 10, 2008 3:03 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 10, 2008 at 06:06 PM

    Setting are ok on the BS. It's on the Integration Process (BPM) that it's not.

    Rgds,

    Yves

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 10, 2008 at 07:16 PM

    Thanks Sarvesh, it worked on the ALEAUD back. Still getting an error on the inbound idoc ack. No receiver agreement on this one since it's a BPM. Is there a way to do the Header Mapping in the BPM directly?

    Rgds,

    Yves

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 10, 2008 at 07:17 PM

    Another question

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 11, 2008 at 12:59 PM

    Thanks!!!

    Add comment
    10|10000 characters needed characters exceeded