Skip to Content
0

Login to Cloud Foundry Environment API Endpoint

Dec 22, 2017 at 02:06 PM

261

avatar image

Hi

I am trying to login to the Cloud Foundry Environment (API Endpoint https://api.cf.eu10.hana.ondemand.com) both using the CF CLI and the CF Eclipse Plugin. In both cases the login fails.

CF CLI: Credentials were rejected, please try again.
RESPONSE: [2017-12-22T09:58:15+01:00]
HTTP/1.1 401 Unauthorized
...
Www-Authenticate: Basic realm="UAA/client", error="unauthorized", error_description="Bad credentials"

CF Eclipse Plugin: Wrong email or password - 403 (Forbidden) - 403 Access token denied.

I am using the same credentials (email, password) as for login to my SAP Cloud Platform (trial) account / SAP Cloud Platform cockpit.

Is the Cloud Foundry Environment using a different account / different credentials?

Thanks and best regards

Heiko

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Ivan Mirisola
Dec 22, 2017 at 03:14 PM
0

Hi Heiko,

I was able to login to my api end on eu10 without any problems. Are you sure you have an account there?

Please login again on the cockpit and also check that your trial period hasn't expired as well (there is a new icon at the top right corner which indicate the trial period in days - if it is equal to zero, than chances are your period has already expired. If this is the case, you may need to apply for an extension period).

Also, open the cloud cockpit on your "subaccount" and check the API endpoint for your organization is the same you are currently using. If they are indeed equal, please open an incident on SAP Support System for further investigation.

CF Accounts for trial can be provisioned at different locations now: us10(AWS), us20(Azure), us30(CGP/BETA) and eu10(AWS).

Maybe you think your trial has been provisioned at eu10 whereas it in fact at another infrastructure.

Regards,
Ivan

Share
10 |10000 characters needed characters left characters exceeded
Heiko Küst Dec 27, 2017 at 09:32 AM
0

Hi Ivan

Thanks for your answer. I double-checked everything (account, expiration, API endpoint). To me it seems correct, but I still get the error.

Now i wanted to open an incident, but as it is a trial account only, i am not able to select the product and installation in the Support Launchpad. SAP states that "SAP does not provide support for SAP Cloud Platform, free edition". Any ideas how to proceed?

Best regards

Heiko

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Heiko,

Have you tried to disable the CF account and re-enable it. I've seen issue with CF subaccount creation before.

Are you using your e-mail credentials? Did you check on SAP ID Service if you have two user ids assigned to the same email? I have seen issues with users registered more than once on SAP ID Service before. Perhaps, your email used to login to the Cockpit has another ID (not the same CF is reaching) and thus the password is incorrect. If SAP ID Service has two IDs assigned (i.e.: P-User and S-User) to the same e-mail, you really need to open a ticket to remove the extra assignment (if you aren't able to remove it from the SAP ID Service UI).

Another option would be to register on SAP ID Service with another e-mail account you have access to. Then, try creating the CF trial sub-account once more.

Regards,
Ivan

0