Skip to Content

SDI FlowGraph - changes to Table not updated automatically

Hi there, I am using SDI flowGraph to load the data from one table to the other as part of my daily ETL process. If there is any change to the table fields, let us say, I added a new field, my flowGraph does not show me the table structure updated with new field. Every time, I have to open the flowgraph and reinsert the same table, so that it gets the new field. Let us say, if I have 30 flowGraphs using the table, I should go and re insert the table in each one. While making the re insert, I am loosing the data field mappings, Writer properties etc. and redoing them. I am wondering, if there is any fix to it.

I tried updating the FlowGraph in HANA Studio and also HANA Web Workbench, both did not get what I was expecting.

We are on HANA 2.0 SP 2.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Nov 14, 2018 at 10:51 PM

    Did you find a solution for that . I am facing same issue.

    Add comment
    10|10000 characters needed characters exceeded

    • I can only get my datasource updated automatically, but not the target table. for the datasource, I can choose Reconcile option and see the differences in the new objects and get that version easily. However, target table, I will have to remove and re add it to the dataflow and maintain the settings again.

      We are in 2.0 SP 03, it is the current behavior, I am not expecting this get resolved. Since we are moving away from Web Workbench or HANA Studio soon, to the Web IDE for HANA.

      comparison.png (26.3 kB)
  • Nov 16, 2018 at 06:00 PM

    I sure did but to no avail.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 16, 2018 at 06:55 PM

    Thanks Sreekanth. Same with me, i was able to get the latest version in source but not in target table. Thanks for taking time to reply.

    Add comment
    10|10000 characters needed characters exceeded