Skip to Content
0

SAP Netweaver 7.51 SP02 Developer Edition installation issue, NPL failed

Dec 20, 2017 at 08:24 AM

237

avatar image

Here is my issue:

/tmp/sapinst_instdir/NW73/SBC/STANDARD/instana.xsl a 16:14:07.137 (root/sapinst) (startInstallation) [/bas/749_REL/bc_749_REL/src/ins/SAPINST/impl/src/syslib/process/syuxccuren.cpp:546] id=syslib.process.currentProcessEnv.cwdSuccessful CSyCurrentProcessEnvironmentImpl::setWorkingDirectory(const CSyPath& /tmp/sapinst_instdir/NW73/SBC/STANDARD) Working directory changed to /tmp/sapinst_instdir/NW73/SBC/STANDARD. ################################################ Abort execution because of Step returns modlib.jslib.caughtException ############################################## Installation of NPL failed, please check logifiles in /tmp/sapinst_instdir for possible root cause.

I know there are some posts about this I have read them already, but none of those solved the problem.

I have also tried ./install.sh -g and I got the error:

My Linux(VM) kernal version is 4.4.90-92.50-default and SUSE version is:

VERSION="12-SP2"

VERSION_ID="12.2"

PRETTY_NAME="SUSE Linux Enterprise Desktop 12 SP2"

ID="sled"

Actually, I got it installed successfully in the same environment.

But this time it seems like not working.

Could anyone help?

install-g.png (9.6 kB)
10 |10000 characters needed characters left characters exceeded

Can you find and post the exact error message in one of the log files in /tmp/sapinst_instdir ?

Else we are not able to help you.

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Uwe Fetzer Dec 20, 2017 at 11:40 AM
0

Hi Eric,

you may try to use the "old" installer: ./sapinst SAPINST_SLP_MODE=false

(worked for me on Ubuntu)

Cheers, Uwe

Edit: Just saw, that your question is about the Developer Edition. Not sure whether the solution also works with it.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Looks like I don't have this option.

0
Eric Yu
Dec 24, 2017 at 03:50 AM
0

I know where is the problem.

This version of NetWeaver only works on openSUSE or SLES.

My Linux is SLED, that was the reason why installation failed.

Share
10 |10000 characters needed characters left characters exceeded