Skip to Content

SAP Functional Unit Configuration (FUN - SLD) - reset status of a Functional Unit

Dec 19, 2017 at 03:39 PM


avatar image

Hi all

We are resuming a FUN set up of a PO system we started a couple of months ago and are now continuing as we set up load balancers.

I'd got half way through the "Process Integration and Orchestration Package Functional" Unit.

To start it off again, I've disabled it (and the pre-requisite units) and been able to start a 'Enable Automatically' wizard.

All very well, but it doesn't do all the steps it did previously. It shows there being 78 steps whereas I have screenshots from previous runs/systems where there were 365 steps.

However, we get to step number 48 which is 'Default Principal Mapping', accept the default details and click next. According to my document, step 81 'Advanced Adapter Engine Extended: Technical Data' should be next, but no - it completes 'all' 78 steps and is done!

Yet we're pretty sure it hasn't done. For a start, we can see it hasn't created any of the users (PIAFPTD, PIRWBPTD etc) it should do in step 81.

If we try and proceed with the next step 'PI AEX SLD Self Registration' this fails with errors suggestion several things are missing/haven't been set up. We can see the CPACache is empty for example, dir/admin Aii Properties haven't been set etc etc.

It needs to run fully through the "Process Integration and Orchestration Package Functional" process but only will ever do these 78 steps! We've tried disabling and enabling a few times, even disabling every Functional Unit we ever enabled to 'start from scratch' but it always ends up the same.

If there some 'hard reset' we can perform?



sld | fun
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Ross Armstrong Dec 20, 2017 at 12:18 PM

Restarted the system and also made sure all the previous functional units had been disabled before starting again - worked this time!

10 |10000 characters needed characters left characters exceeded