Skip to Content

Fiori Front end UI Components Issue in s4hana 1610

Dec 19, 2017 at 03:14 PM


avatar image

Hi All,

We have installed the below UI Components in Front end server of S4HANA 1610 hub architecture. But while accessing FLP i have checked the SAPUI5 library version it is showing "1.38" with old sap blue crystal theme because of that i am not able to use the latest features of fiori 2.0, since we are in SAP_UI 750 and S4HANA 1610 i think library version will be 1.40 above if i am wrong which UI Component basis guy should upgrade to get 1.40 plus library version and fiori 2.0 features in FLP.Please help me on this.

Thanks in advance.


ui-screen1.jpg (58.4 kB)
ui-screen2.jpg (32.4 kB)
flp.jpg (25.6 kB)
10 |10000 characters needed characters left characters exceeded

Install FIORI FRONT-END SERVER 3.0 on your front end system - this is a prerequisite for Fiori 2.0.

Reference - SAP Fiori 2.0 – What you need to know


Hi Saurabh,

Thanks for the reply.Can you please suggest me the components for FES 3.0? it will be helpful for me to suggest basis guy to install those components.

purushotham padigireddy

You can ask your Basis team to download the required components by going to software downloads on service marketplace and navigating to SAP FIORI -> SAP FIORI FOR S/4HANA -> SAP FIORI FRONT-END SERVER -> SAP FIORI FRONT-END SERVER 3.0


Thank you Saurabh, will check with basis team.

* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Frank Schuler
Dec 20, 2017 at 06:37 AM

Hello Purushotham,

For SAPUI5 1.40 you need SAP_UI 751 SP00 and for SAPUI5 1.44 you need SAP_UI 751 SP01. For reference please check:

What's New in User Interface Technology 7.51 (SAP_UI 751)

The good news is, that you do not have to upgrade the whole of your SAP NetWeaver stack, but just component SAP_UI.

Best regards


10 |10000 characters needed characters left characters exceeded