Skip to Content
author's profile photo Former Member
Former Member

Relationship import | Import manager

Hi ,

I am trying to import relationships through import manager in the material repository . What I do is , there are some existing relationships that I created in the data manager . I export them first [ data manager > relationships > export to a file ] to a file and then make changes to the existing file . I use the same file to import relationships but this time with the import manager . I have the following column names in my ".TXT" file ...

1) material numbe <name of the relationship defined in the console>

2) material number <>

3) quantity

I can successfully map the fields and then when I choose the import action it gives me the following error ...

-


Import failed. Field not found.

Import action: NoneSource record no: 8

-


there is no record in my file actually at number 8 . I removed the last "Enter" from the file and then imported it but with same results . I exported the existing relationships to an excel file and then tried to import it through the import manager but with the same result .

To verify if there is a problem with the file I use the same file to import the relationships through data manager [relationships > import from file > name of the relationship defined in the console ] and I am able to successfully import it .

What do you guys think is the problem ??

Regards

Deepak Singh

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Apr 09, 2008 at 07:46 AM

    Hi Deepak,

    Can you please explain what changes you have made in the text file(eg changing the structure or data).Also which delimiter has been used in the text file?

    According to me the error is with the field and not with the records.

    Regards,

    Jitesh Talreja

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jitesh ,

      I did not make any changes in the data or the structure of the data . Just tried to remove the last "enter" from the file so that the import manager is able to understand that there is no record which is missing .

      TAB delimeter is being used in the file . When I open the import manager I choose the delimited text as the option and the delimeter as "\t" . This representation can be verified by the reference guide for import manger .

      What do you think could the problem be ??

      Regards

      Deepak Singh

  • Posted on Apr 09, 2008 at 08:08 AM

    Hi Deepak,

    You said you have deleted the last Enter also in the file; I hope that should have been only the problem; try again at end of your data select shift button and scroll down and press delete; i hope this will help. And please dont forget to look into the source data in import manager. Once you login successfully into import manager you can find you source data there check for the you correct data under there and even under mapping section, that is when you map the feilds you can see its data at the bottom pane and chage it accordingly, even check you data there for each fields. If find blank field then just put in some sample data.

    Let me know if you face the same problem even after following those steps.

    Cheers & Regards

    Cherry.

    Add a comment
    10|10000 characters needed characters exceeded

    • Deepa,

      To the best of my knowledge the problem shouldn't be with Import Manager; Initally when working with excel I faced the same problem and i used the soultion which i said initally; but i never imported relationship, so i am not sure; but can you make any changes for the relation ships and try it.

      Cherrs,

      Cherry

  • author's profile photo Former Member
    Former Member
    Posted on Apr 10, 2008 at 05:24 AM

    Hi Deepak,

    I had performed the following steps and it worked perfectly fine.

    Just go through them once and check that you have did the same.

    1. Export Relationship using Data Manager -> Relationships -> Export to File.[There is only Display Field i.e. Material]

    2. Imported the same text file with Type="Delimited Text" and Delimiter="\t"

    3. Select the Relationship table from the Destination drop down list.

    4. Map the Parent Material with the Material[Parent] and Child with Material[Child].Also Quantity with the qualifier Quantity.

    5. Execute the import.

    Note : Please dont make any changes to the Text file and try importing.

    Regards,

    Jitesh Talreja

    Edited by: Jitesh Talreja on Apr 10, 2008 7:25 AM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.