Skip to Content
author's profile photo Former Member
Former Member

SMARTFORMS TAKING VERY LONG TIME TO PROCESS..SP01 SHOWS MANY SPOOL REQS..

hello guys,

i am struck with a problem for long now..

i was given a program that executes and smart form and asked to modify the form..(adding some fields)..

after adding some fields,when i execute the program and see i get the following problems,

1)when i fill selection screen and go for EXECUTE AND PRINT...the program takes a lot of time ..and finaly displays status mess that SPOOL REQUEST IS CREATED...

2) when i check sp01 i see many spool requests being created (some 100)

3)when i check one of the spool requst and see for output request none of them is present in list.

in my program these are the only output and controlparameters being passed

n control parameters they pass

p_control-langu = 'EN'.

p_control-no_dialog = 'X'.

in output

p_output-tddest = 'LP05'.

p_output-tdnewid = 'X'.

and for user_settings

user_settings = ' '

whats ther matter?? if i disable control output and user settigns and give them at runtime..i get no issue(and only one spool request)..

so any corrections? suggestions?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Apr 11, 2008 at 05:39 PM

    Get rid of p_output-tdnewid = 'X'.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.