Skip to Content
avatar image
Former Member

abap client proxy to xi - no data found

Hi experts

I m working on abap client proxy to file scenario where in I m sending data from R/3 system to legacy system via xi , but after doing all the configurations and running the abap program for triggering client proxy , i dont find any data on the receiver side ,

I have activated client proxy as per Vijay Kumaris Blog

I checked sxmb_moni on the R/3 system but shows no data selected , so no question of data being found on xi server ,

i m really sutcked up ....dont know hwat to do , pl help

rgds

mojib

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Apr 07, 2008 at 02:48 PM

    Hi,

    Have u used commit work at the end of the code.

    Can you please tell me what all configuration u have done.

    U have referred the ABAP Proxy configuration:

    /people/vijaya.kumari2/blog/2006/01/26/how-do-you-activate-abap-proxies

    Refer the below log for Client Proxy -

    /people/ravikumar.allampallam/blog/2005/03/14/abap-proxies-in-xiclient-proxy

    Chirag

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Can you put the break point in the report and check whether data is filled in the table before it passed to method. Also check whether the method is passed with the proper data or not?

      BY debugging only u can check whether data is really send to method or not?

      Also go to SXMB_MONI on R3 and check the input payload.

      let me know both the results.

      chirag

  • avatar image
    Former Member
    Apr 09, 2008 at 12:27 PM

    thanks guys the problem was from basis end

    Add comment
    10|10000 characters needed characters exceeded