Skip to Content
0

Decimal digits all = 0 in Design Studio Application on BI platform

Dec 20, 2017 at 05:17 PM

43

avatar image
Former Member

Hi,

I have a design studio (version 16.5.4) application based on a universe itself based on a MySQL database.

When I execute the application on the BI platform, the decimal digits in my crosstab are all equal to 0 (like a floor, not an average).

But they are fine in Design Studio (initial view and preview) and when executed Locally (and in WebI).

There is more : when I change the "Preferred Viewing Local" parameter on the BI platform to (English (UK) for example), the decimal digits are correct. (But then I something like this : 1,000.00 and informations in English...).

Sadly, I need to have something like this 1 000,00.

Can anybody help?

Thank you,

Bruno

10 |10000 characters needed characters left characters exceeded

What was the default Preferred Viewing Locale ? Did you check changing it to French (France) ?

capture.png (4.3 kB)
0
Former Member

Hi,

Platform version : 4.2 Support Pack 3 Patch 5.

The default Preferred Viewing Locale was using the browser settings.

I already tried all countries in French and some others.

When the decimal mark is a dot the values are correct, otherwise they are wrong.

0

Sounds really weird. You should seek support from SAP by raising a ticket.

0
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Tammy Powlas
Dec 20, 2017 at 05:30 PM
0

Bruno - please see Karol's reply here: https://archive.sap.com/discussions/thread/3683761 - he walks through browser, etc.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks but I already saw that post.

The problem here is different : the value of the decimal digits are wrong.

Modifying the "Preferred Viewing Local" parameter is just a work around which add format problems.

Regards,

0
Arijit Das Dec 21, 2017 at 09:43 AM
0

I am able to reproduce the same issue at my end. Looks like a bug to me. You should raise a support ticket to SAP.

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I will do that, Thanks for your time !

Bruno

0

If you receive a solution, please update this thread with the same. That will help the community a lot. Thanks.

0

Hi Bruno,

Did you find any solution for this issue?

Thanks

0
Former Member
Arijit Das

Hi,

No, as a workaround, I set the "Preferred Viewing Local" parameter as Swiss (French).

The decimals are correct and the information are in French but I got numbers formatted like this : 1'234.56

Bruno

0