Skip to Content

How to use L_TO_CREATE_POSTING_CHANGE for multiple items

Dec 19, 2017 at 12:26 PM


avatar image

Hi, everyone!

I have to use L_TO_CREATE_POSTING_CHANGE FM from WM, but I'm not able.

To confirm only one item I was successful. However, now I have to create a TO whose quantity is 200 BAG. The loading equipment quantity from each storage unit is 50 BAG, so TO should have 4 items. Any way I do, I'm not able to create TO from FM.

Just a look:

Material document:


From this test, I got the following error:

Can you guys help me how to use this function with many items?

Thanks a lot!


1.png (18.7 kB)
2.png (25.8 kB)
3.png (19.0 kB)
4.png (2.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Marcela Melo Dec 27, 2017 at 06:25 PM

I didn't find an answer to my question, so I solved it unchecking the V_T333-KZUAP flag for mvt 309 (I was using it). Thus, on bulk cases, the storage units go to another storage bin automatically and I get back them with L_TO_CREATE_MULTIPLE fm.

It worked this way to me.

Thanks anyway!

10 |10000 characters needed characters left characters exceeded
Jürgen L
Dec 19, 2017 at 01:52 PM

This error has nothing really to do with the function module.

You have a strategy which does not allow the mixed storage that is required for that what you want to do.

You have 4 quants because of 4 storage units, so you would at least need indicator A for mixed storage in your customizing of the storage type.

You should actually get the same error in LU04.

Show 3 Share
10 |10000 characters needed characters left characters exceeded


Actually, in LU04, TO was created successfully:

This happens in bulk bins. I thinks I'm filling up the T_LUBQU table wrong.

5.png (40.3 kB)

Can't you just debug this and see what exactly causes the message to appear (or not to appear in the transaction)?


I debugged, but I didn't find anything. Apparently, LU04 doesn't use L_TO_CREATE_POSTING_CHANGE and validation to both cases is different. I searched for notes, but I didn't find them either.