Skip to Content

Text formatting for workitem description in SBWP

In a workflow task I added a description for the task wehere I added an expression from the Workflow Container. This expression contains html. When I add this expression as comment (/*) the HTML is displayed very ba in SBWP.

The HTML Text seems correct:

<p><strong>Nein Nein Nein</strong></p>

If I add the this HTML Text directly as comment(/*) it is displayed with the correct formatting. Only when I use the Expression from the container(which contains the same value) it is displayed false.

My Description(bad formatting):

Anyone could help me with that problem? :-)

question1.png (7.1 kB)
2.png (11.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Oct 06 at 09:51 AM

    Hello,

    When you are adding HTML Text in workflow work item text, try to add it using option 'Expression'.

    After clicking on Expression option it asks you which container elements you want to display in the work item. When you choose the appropriate element from the container, if it's a multi-line container element if asks you the options for displaying data such as -

    1.Only first line

    2.All lines as continuous text

    3.All lines with line break

    Select the required option and check whether you get the expected output in work item text.

    Regards,
    Rupali Patil.

    Add comment
    10|10000 characters needed characters exceeded

  • 5 days ago

    Hi,

    follow the formating recommendations of

    SAP Note 2472157 - Work item description with HTML table in expression is not displayed correctly

    Best Regards
    Laszlo

    Add comment
    10|10000 characters needed characters exceeded