Skip to Content
avatar image
Former Member

Language Customizing

Hi! Everybody

When we do a logon with our language (Spanish) we can see the data of our customization. But if we do the same in English we can not see data.

Can anybody tell us how we can fix it ? We woold like to see the data either in Ensglish or Spanish.

Thank you very much

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Apr 02, 2008 at 04:48 AM

    Hi,

    If I understood your question correctly, then you want to see both english and spanish language data on the MI client based on the logon language.

    Actually it matters with what logon language you have used when synchronizing with the middleware when registering the device initially and data with that logon language will be downloaded to the client. So that is the reason why you are able to see the spanish data when you logon to the client because I think you might have used spanish as language when you initially registered your device.

    At any point of time there will be data with only one particular language on the MI client and it is usually the language which you have used while registering and you can only see it in your application if you use the same language while logging into the MI client. If you change the language during logging to the MI client it doesn't help because the data set is not available.

    So I would suggest you to reset your client when you want to change the data set with a particular language and then sync with the middleware so that you get the required langauge content.

    Hope the reply helps.

    Best Regards,

    Siva.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 02, 2008 at 08:42 PM

    Hi! Siva

    I am talking about SAP Logon. Not logon on the Client.

    I am talkng the information displayed for example with IW39, ........ customizing.

    Thank you

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Xiomara,

      look into your customizing and the language data of the object. If you have not entered an english text for that object - and you log on in english - then nothing is displayed here - well - logical that far.

      Now you can set the default language of the system - usually this is english. When you logon with a language to the system and no entry is available for that object in that specific language the system takes the default language to display at least some text. In ypour case the default language seems to be english - that is the default setting for default language. Well..... And that is the case why you do not see anything: all your entries are done in Spanish....

      Hope that helps why talkoing to business and basis people.

      Regards,

      Oliver

  • avatar image
    Former Member
    Apr 03, 2008 at 02:42 AM

    Hi,

    If it is with the data on the backend, make sure that you have some data with the language you are logging in. Only if you have data with all the languages then only you can see data of different logged in language.

    I would suggest you to create few entries when you logon with english language and then relogon to your system and see if they are still displayed.

    Best Regards,

    Siva.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 03, 2008 at 12:02 PM

    Hi

    When you are loged on in Spanish, and go into customizing, you select the topics you wan't to tanslate fx. inside iw39, in one of the menues there is a translation point, as far as I remember it is under goto ot edit, then you will get a popup, where you can select language, only select english, and say ok.

    Then all the items will come in a list with the filled spanish name, and the unfilled english name.

    This works for most translation relevant objects.

    Br Jan

    Add comment
    10|10000 characters needed characters exceeded