Skip to Content

Could not load Sybase.AdoNet4.AseClient.32bits.\sybcsi_core210.dll

Dec 15, 2017 at 02:36 AM


avatar image

Our application got error on Windows XP SP3(.Net Framework 4.0).
The type initializer for 'Sybase.Data.AseClient1.AseConnection' threw an exception. --->
Could not load C:\Documents and Settings\user_name
\Local Setting\Temp\Sybase.AdoNet4.AseClient.32bits.\sybcsi_core210.dll
at Sybase.Data.AseClient1.AseConnection.SaveAndLoadLibrary(String directory_name, String dll_name, Int32 bits)
at Sybase.Data.AseClient1.AseConnection.LoadLibraries()

at Sybase.Data.AseClient1.AseConnection..cctor()

--- End of inner exception stack trace ---

at Sybase.Data.AseClient1.AseConnection..ctor(AseConnection realConnection, String connectionString)

at Sybase.Data.AseClient.AseConnection..ctor(String connectionString)

at GCM.BSS_Connection.Init(String p_gConnect)
After checking, we could not find Sybase.AdoNet4.AseClient.32bits. in user profile Temp folder.
We have tried to solve the procblem by
1. re-create the user profile or
2. copy Sybase.AdoNet4.AseClient.32bits. from developer machine to the user profile
But still got the error.
Our application is built by VS2015, target framework is .Net Framework 4.0,
Sybase.AdoNet4.AseClient.dll (v16.0.2.3).

Has anyone experienced this problem ?

Please help, how to fix it or workaround.

Thanks you and best regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Anthony Moran Dec 19, 2017 at 02:50 AM

We installed .net framework 2 SP2 and it works now. Thanks

10 |10000 characters needed characters left characters exceeded
Alberto Merino
Dec 15, 2017 at 10:35 AM

Please check

You are running

Windows XP SP3(.Net Framework 4.0).

But we only support ..

  • Microsoft Windows 2008 R2 x86, Service Pack 1 or later
  • Microsoft Windows 2008 R2 x86-64, Service Pack 1.0 or later
  • Microsoft Windows 7 x86-64

Please run test in Windows 7. Thanks

Show 1 Share
10 |10000 characters needed characters left characters exceeded

We are using v16.0.2.3. Thanks