Skip to Content
0
Former Member
Mar 31, 2008 at 08:25 AM

Short dump when trying to intall 0D_FI_C01

13 Views

Hi,

I came across the short dump of OBJECTS_OBJREF_NOT_ASSIGNED when trying to install the democube of 0D_FI_C01. Below is the short dump message. Please advise on the step by step on how to solve this.

METHOD after_activation_db .

  • impact to tlogo types IOBJ

DATA: l_r_msg TYPE REF TO cl_rso_msg.

CREATE OBJECT l_r_msg.

  • specific coding only in redefinition (for CHA so far)

  • 30B SP08 InfoObjects -> is moved to here form AFTER_ACTIVATION sinc

  • new SIDs have to be determined for a changed SID table

  • if the reference was changed

CALL METHOD check_vers_a_iobj_impact

EXPORTING

i_r_vers_a = i_r_vers_a

i_th_tlogo = i_th_tlogo

i_check_mode = rs_c_false

i_detlevel = i_detlevel

CHANGING

c_subrc = c_subrc

c_r_msg = l_r_msg.

  • ODS specific actions

  • 30B SP11 reset ODS activation templates if pure attribute flag was

  • changed for a unit or a characteristic

IF n_s_iobj-atronlyfl <> i_r_vers_a->n_s_iobj-atronlyfl AND

n_s_iobj-iobjtp <> rsd_c_objtp-keyfigure.

  • get usage in ODS objects

DATA: l_t_ods_usage TYPE rso_t_tlogo_asc.

DATA: l_s_ods_usage TYPE rso_s_tlogo_asc.

CALL FUNCTION 'RSD_IOBJ_USAGE'

EXPORTING

i_iobjnm = n_s_iobj-iobjnm

i_th_tlogo = i_th_tlogo

IMPORTING

e_t_odso = l_t_ods_usage.

reset the program status

MESSAGE s234(r7b) WITH n_s_iobj-iobjnm INTO o_dummy_msg.

IF NOT l_t_ods_usage IS INITIAL.

CALL METHOD l_r_msg->add_msg( i_detlevel = i_detlevel ).

ENDIF.

Cheers