Skip to Content
avatar image
Former Member

how to restore db backup data file to a remote db server

Hello, everyone

I had one db recovery problem making me headache. Maybe you can give me some hints.

The question is:

1. I have a backup medium file named initdb

2. I can retore it in local computer.

3. I want to restore it to db1 in remote computer by using dbmcli in local computer.

See computer1 is local computer , computer2 as remote computer.

The command series executed in computer1 are like the followiings:

computer1> dbmcli -n computer2 -u dbm,dbm -d db1

dbmcli on computer2: db1> medium_put initialdb_recover
computer1\temp\initdb file data 0 8 no

dbmcli on computer2: db1> db_admin

dbmcli on computer2: db1> db_connect

dbmcli on computer2: db1> db_activate recover initialdb_recover

I got the following errors:

ERR

-24988,ERR_SQL: SQL error

-903,Host file I/O error

6,Data recovery failed

1,Backupmedium #1 (
computer1\temp\initdb) access denied [5]

6,Backup error occured, Errorcode 3700 "hostfile_error"

17,Servertask Info: because Error in backup task occured

10,Job 1 (Backup / Restore Medium Task) [executing] WaitingT72 Result=3700

6,Error in backup task occured, Errorcode 3700 "hostfile_error"

I thought that maybe I need to define a pipe but I can not figure out a way to define it pointing to
computer1\temp\initdb.

Wish your kind help.

Thanks

chu

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Mar 29, 2008 at 09:48 PM

    Hi again chu,

    the problem here is the Windows authentication.

    > 1,Backupmedium #1 (
    computer1\temp\initdb) access denied [5]

    That error means: the MaxDB Kernelprocess tried to open shared Windowsfile but the user that is running the Kernel does not have the rights to do so.

    It's the same user that runs the MaxDB service - usually it's "Local System".

    The easiest solution to this may be to create a new user, assign this user access rights to the share and the backup file and run the MaxDB service with this user.

    You may also set the parameter "USE_BACKUP_SECURITY_DESCRIPTOR" to NO in order to access the file w/o authentication. But than the share/file permissions have to allow unauthenticated full access to this file.

    KR Lars

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Chu,

      ok, step by step ...

      >

      > 1. dbmcli on maxdb1>util_execute clear log

      > OK

      Fine...

      > 2. dbmcli on maxdb1>recover_start DBLOG LOG 001

      > OK

      > Returncode -7075

      > SEEMS NOTHING HAPPEND.

      -7075 means: this log cannot be recovered now. It could be that this logfile does not contain any "new" data so that the data won't be changed. This could happen if the data backup contains a version of the database that was saved by a savepoinz after the log segment saved in log.001 was written.

      Therefore: Ok, but nothing is done.

      > 3. dbmcli on maxdb1>recover_replace DBLOG LOG 002

      > ERR

      > -24988,ERR_SQL: SQL error

      > -104,DBM command impossible at this time

      As the log recovery did not actually start with step 2 (since it was the wrong log backup) you cannot "replace" the log but have to start the logbackup first.

      > So I tried another way below:

      >

      > 1.dbmcli on maxdb1>recover_start DBLOG LOG 002

      > OK

      > Returncode -8020

      -> Ok, data from the second logfile was recovered and now you can either stop the recovery by recovery_ignore or put in another logbackup by recovery_replace.

      >

      > 2. dbmcli on maxdb1>recover_replace DBLOG LOG 003

      > ERR

      > -24988,ERR_SQL: SQL error

      > -3004,Invalid host file sequence

      > 1,Backupmedium #1 (LOG.003) invalid file or device name [2]

      > 6,Backup error occured, Errorcode 5220 "wrong_hostfile"

      > 17,Servertask Info: because Error in backup task occured

      > 10,Job 1 (Backup / Restore Medium Task) [executing] WaitingT71 Result=5220

      > 6,Error in backup task occured, Errorcode 5220 "wrong_hostfile"

      --> is there a third log backup file ??? If not the message is pretty self-explaining ...

      > It looked like that if I can start with log 002, but can not continue the next log 003.

      > I can not understand this!

      > Maybe I did something wrong? This really make me crazy.

      Don't give up now - you're nearly done... 😊

      kind regards,

      Lars