Skip to Content
0

CR for VS 13.0.35 Dynamic List of Values(LOV) and Incorrect Parameter

Dec 15, 2017 at 01:53 PM

786

avatar image
Former Member

I have a bunch of reports that use a Dynamic List of Values parameter. None of these report work in Crystal Reports for Visual Studio 13.0.35. I have tried making new reports as well. Without failure when I add a parameter field and set List of Values to dynamic the report will not run. It crashes both Visual Studio 2013 and 2010. I have tried using SQL Server and Excel files as data sources. The results are the same. Please help. The reports when run in compiled application produce incorrect parameter instead. Please see the video for a sample.

Here is a link to a demonstration of the problem. https://onedrive.live.com/?authkey=%21ADck18bzqhmmAbc&cid=F02B1D32FD09ADF0&id=F02B1D32FD09ADF0%21184057∥Id=F02B1D32FD09ADF0%21184051&o=OneUp

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Don Williams
Jan 02 at 03:30 PM
0

Hi James,

It does work, since you are using SP 21, 13.0.3500.0, try this sample app:

https://blogs.sap.com/2016/02/17/how-to-parameters-in-crystal-reports-for-visual-studio-net/

It needs to be updated to the 3500 assemblies as well.

Once updated you need to set log on info so it can connect to the DB to query for the LOV. Once connected then in the drop down list box on the right you'll see a Parameter link. Click it and see if it gets the values.

Don

Share
10 |10000 characters needed characters left characters exceeded
Dell Stinnett-Christy Dec 20, 2017 at 03:57 PM
0

Please go to Control Panel >> Programs & Features and let us know which service pack of Crystal for VS you have installed. The latest SP is 21.

-Dell

Share
10 |10000 characters needed characters left characters exceeded