Skip to Content

Write Back Badi - Data Issue


I have an input template with account in columns and time in rows. I have written a WRITE BACK Badi. In Time i have selected Q4.2017 (members and Decedents). My Badi is to read the members of Q4.2017 which is 10.2017, 11.2017 and 12.2017 and to distribute the data equally.

If I save the data for GL account and Q4.2017 as 100, it needs to spread 33.33 for 3 months and Q4.2017 should be the total ie, 100.

The issue i face is

1. I pass 100 to Q4.2017, data is save with a message Records saved : 1, But actually there are 3 records saved. How to change to the correct record count?

2. 33.33 is distributed to 3 months and is displayed as 33.33 but even in Q4.2017 - 33.33 is displayed, but it should be 100. I have refreshed the report but still no use. I haven't enabled calculate parents in hierarchy option. How to make it to display as 100?

-- Selva.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Dec 14, 2017 at 07:21 AM

    1. It's by design. Only one value is counted.

    2. May be you are talking about YTD account? ACCTYPE AST or LEQ in Periodic model or all types in YTD model?

    P.S. Are you talking about this code: ?

    Add comment
    10|10000 characters needed characters exceeded

    • Explaining third time - when model is YTD then ALL account types are YTD and the Q4 result will be equal to 12.2015 result. This is absolutely basic BPC knowledge.

      Also your badi is working incorrectly for YTD model: instead of equal distribution you have the same YTD figure for all months.

      Test your badi on PERIODIC model!