Skip to Content

Input parameter not passed from one HANA view to another

Dec 13, 2017 at 02:15 PM


avatar image

Hi experts,

my input parameters are not passed from one Calculation View to another, eventhough I mapped them with the "auto map" feature.

I am wondering what I am doing wrong, as (I think) I followed the instructions posted on

Here is what I did:

I have created a HANA view with an Input Parameter hierid:

I have left the Default value blank because I want to pass it flexibly from a second view. In the second view, I joined the first view and then under "Semantics" and "Parameters/Variables" I Chose "Input Parameter Manage Mapping". I Chose "Auto Map By Name" which automatically created the HIERID Parameter in the second view and defined the mapping:

Then I activate and choose "Data Preview". In the popup, I enter a value for the Parameter:

I click on okay and drag a field of the Column View onto the Labels Axis. The System Shows that the hierid variable was not set:

Can you tell me what is going wrong here?

Thanks so much for your ideas!


unbenannt.png (127.8 kB)
unbenannt2.png (104.6 kB)
unbenannt3.png (86.1 kB)
unbenannt4.png (156.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Thilo Knötzele Dec 13, 2017 at 02:32 PM


Is it possible that there is something wrong only with the data preview? When I copy the SQL from the Log and paste it in the SQL Console, I get the correct data:



unbenannt5.png (99.8 kB)
10 |10000 characters needed characters left characters exceeded