Skip to Content

PowerDesigner entity definition does not retain pasted images/screenshots in rich text editing

When I edit the 'definition' tab of an entity or table (which allows rich text), it allows me to paste in an image from the clipboard. But after saving, and then re-opening, it is gone.

I realise that pasting images/screenshots is not something to do often (due to model size) but if the editor allows it, why is it not saved? Is this a bug?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Dec 12, 2017 at 09:58 PM

    This isn't really an answer to your question, but a work-around that may help you - try using an external editor to edit the description. Look on the tool bar at the top of the description - the second tool in from the left allows you to lauch an external editor. In my case, it launches Microsoft Word.

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks George, but unfortunately that didn't work for me either. The text box didn't display the image after saving the Word doc, and the Word doc itself didn't retain the image either, when reopening.

      I'll raise it as a bug or feature request.

  • Dec 20, 2017 at 04:59 PM

    Hello, I do not seem to be able to reproduce it running PD 16.6.5.1.
    I drawn something in Ms Paint (500x250, 96 DPI), selected all and pasted it to the Entity's description tab.
    I saved, closed then reopened the model: the picture is still there.
    KR

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Arnaud,

      I now have 16.6.5.2 but pasting an image into an entity's Definition>Description tab still does not retain it for me. In fact, it disappears as soon as I press 'Apply'. I'll report the problem to SAP and see what they say.