Skip to Content
author's profile photo Former Member
Former Member

Blank entry is not getting updated in r/3?

Hi Gurus,

I have a webdynpro application which has user input field where in which user can pass the data and it will get updated once user hit the update button in the view.

But in some case if user don't enter any value in the above said input box it has to update the r/3 with the blank entry.

But in my case r/3 system refers the value (which is passed from portal last time) instead of blank entry?

How to overcome this problem.

Please Help

Thanks in Advance,

Dharani

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Mar 26, 2008 at 03:04 PM

    Hi,

    you try to set the input box with blank entry.

    for eg.

    if(wdContext.currentContextElement.getNodeAttribute()==null || (Or operator) wdContext.currentContextElement.setNodeAttribute("")=="")

    wdContext.currentContextElement.setNodeAttribute("");

    use the conditional statement to check the data and set it to the Attribute , as this is going to be updated .

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      For your Function Module (SE37) , Check the import parameters and export parameters .

      If any export parameter ,,, say rcode -- is of type --sy-subrc

      Suppose your FM is like this ..........

      // some code

      // update ......

      now sy-subrc value ..will be in the function module say 0 if update executed sucessfully otherwise a non-zero.

      As you are exporting the value through rcode...export variable , you can just print the value of rcode in the WD application ....after executing in that backend FM in WD ...by passing the input parameters.

      Thanks ,

      Srini

  • author's profile photo Former Member
    Former Member
    Posted on Mar 27, 2008 at 02:06 PM

    Hi Dharani,

    You can try this way;

    On action trigger, check the inputvalue node size, and if its zero set the input values as BLANK .

    This way it has to work.

    point: Make sure that your table is not set with any keys

    Try this and let us know the result

    Regards

    - Vinod

    *

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.