Skip to Content
avatar image
Former Member

Disable keyboard shortcuts NWBC

Hello everyone,

Just a quick question, is posible to disable (or change) keyboard shortcuts in NWBC?

I use very often Ctrl+left/right to move across text, but in NWBC that shortcuts are to move tabs.

Regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 20, 2016 at 10:02 AM

    Hi!

    You can try to change shortcuts as described here: https://blogs.sap.com/2015/03/02/wks-how-to-use-nwbc-in-tm-installation-and-basic-setup

    At least it helped for me. I changed Ctrl to Alt:

      <Nwbc40Commands>
        <NwbcCommand>
          <ID>MoveCurrentTabLeft</ID>
          <Key>Left</Key>    
          <ModifierKeys>Alt</ModifierKeys>
          <Description>Move Left</Description>
        </NwbcCommand>
        <NwbcCommand>
          <ID>MoveCurrentTabRight</ID>
          <Key>Right</Key>    
          <ModifierKeys>Alt</ModifierKeys>
          <Description>Move Right</Description>
        </NwbcCommand>
      </Nwbc40Commands>
    
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi everybody ,

      I looked at many sources to change the keyboard settings, but none of them did not work in NWBC 6.5. I could not change the combination of Ctrl + Left and Ctrl + Right..

      I added following codes on the this location NwbcOption.xml file . C:\Users\Yunus\AppData\Roaming\SAP\NWBC\NwbcOptions.xml

      ....<Nwbc40Commands><NwbcCommand><ID>MoveCurrentTabLeft</ID><Key>Left</Key><ModifierKeys>Alt</ModifierKeys><Description>MoveLeft</Description></NwbcCommand><NwbcCommand><ID>MoveCurrentTabRight</ID><Key>Right</Key><ModifierKeys>Alt</ModifierKeys><Description>MoveRight</Description></NwbcCommand></Nwbc40Commands></NwbcOptions>

      After that , I changed Personel Settings like that.

      But when I NWBC opened , It show error like that . (Key parameter can not be null. ) But I Filled it .. And It didn't change any things..