Skip to Content
author's profile photo Former Member
Former Member

Problem with values in the Infoobject 0EMPLOYEE

Hi,

I have extended the Datasource 0EMPLOYEE and have added one field ZSTATUS (Modified the structure, as well as wrote code in CMOD to populate the field). When I run in RSA3, in the Source System the values are getting dispalyed properly. Also, when I run the InfoPackage, the data gets loaded into the PSA properly (Processing Option is PSA and then in the Infoobject)

The problem is when I look into the tables /BI0/MEMPLOYEE the values are not getting populated properly. It populates the last value of the ZSTATUS field in all the records. For e.g. A single employee could have 8 records, which are delimited by Time stamps(DateFrom and DateTo). They have different values for ZSTATUS field at different times. But, in the /BI0/MEMPLOYEE all of them have the last value.

Also, the other thing that I noticed is when I go to "Maintain Master Data" for 0EMPLOYEE and I execute for a single employee. It gets the 8 records. Now, if I go and change the value of ZSTATUS for one record it changes the value of that field in all the eight records.

This is not the case for some of the existing fields like PayArea, where when i change for the field it changes only for that record.

Please let me know your thoughts.

Thanks,

Ani

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Mar 24, 2008 at 04:31 AM

    The reason for this was because we did not have the Time Dependent indicator of the attribute was not checked..

    Thanks,

    Ani

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.