Skip to Content

When i want to logon on NWDI, the old user still fixed there, how to switch anther user id ?

Dec 08, 2017 at 02:18 AM


avatar image

On the pop-up windows "Logon on to Development Infrastructure", the "user id" is fixed and cannot change , the old user id is expired. Anyone can tell me how to change the logon user ?

Thanks in advance.

10 |10000 characters needed characters left characters exceeded

Would you please elaborate a little bit...

where do you logon to the NWDI: from the NWDS or from the UI of the NWDI?


From : SAP NetWeaver Developer Studio SAP Enhancement Package 1 for SAP NetWeaver Developer Studio 7.3 SP18 PAT0001.

At : Component Browser


* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Milen Dontcheff
Dec 08, 2017 at 09:10 AM

Would you please try to "reset" the Secure Storage in the NWDS.

Please start NWDS , go to Window -- Preferences --> General -- Security -- Secure Storage --> click on the tab "Contents" --> select the item "Default Secure Storage" and press Delete. After this restart NWDS.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

sorry, it is not work, maybe i am not describe clearly. Under "component Browser", except "LocalDevelopment", another "Development Configuration" is here named "A", when i want to logon A, the user is fixed there, it just allow to input password, i want to change the user id to mine.

thanks in advance.

James Duan Dec 11, 2017 at 03:13 AM

Milen, Thank you. I had solved this issue.

Delete the old DI configuration, then add new one.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

btw, I played around and in the Development Infrastructure perspective,

at the tool bar there should be a "logon" button

When it is selected it should be possible to change the user credentials.


logonbutton.png (740 B)

Since the old user is invalid (resigned), so must to delete the old configuration, otherwise, the user id cannot be changed. so ...

Anyway, thanks a lot.