Skip to Content
avatar image
Former Member

SXI_CACHE - complete refresh not working.

All,

we moved our components to a different environment (regular file based export/import). when we see the cache notifications under the "Environment" menu - we see all the statuses as green.

when we check the sxi_cache, the status there also is green. but the problem is - the sxi_cache doesnt have the time stamps updated for the last import. (and it is still showing some objects that were deleted and no longer in the environment).

when we do a complete refresh, nothing gets updated. This is what i did.

1. i did a complete cache refresh.

2. i went to sm37.. and saw that the job SWEQSRV was scheduled under my user id.

3. I released it and it immediately completed and here is the job log -

Job started

Step 001 started (program RSWEQSRV, variant &0000000020931, user ID xxxxxxx)

Job SWEQSRV is not active - cancellation not possible!

Job finished

Is this right? or am i missing something here?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 19, 2008 at 02:23 PM

    Hi rk,

    1.

    Refer the below weblog:

    /people/sravya.talanki2/blog/2005/11/03/cache-refresh-errors--new-phenomena

    Your : INTEGRATION_DIRECTORY_HMI RFC is working correctly?

    INTEGRATION_DIRECTORY_HMI (HTTP connection, use the XIISUSER to authenticate). Is the

    Path Prefix set to “/dir/CacheRefresh”.

    also check those in exchangeprofile:

    com.sap.aii.integrationserver.serviceuser.name

    com.sap.aii.integrationserver.serviceuser.pwd

    2. refer this link, this may help

    http://72.14.235.104/search?q=cache:ybo3lXQMIqMJ:https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/c00d9465-ea97-2910-deac-f8aa681eef35sxi_cacheobsolute+why%3F&hl=en&ct=clnk&cd=1&gl=in&client=firefox-a

    http://help.sap.com/saphelp_erp2005vp/helpdata/en/44/3a6c6d55e402bfe10000000a11466f/content.htm

    3. Check the RWB cache notifaction status for the AE and IE? these should be green in color...when you run SXI_CACHE it tries to push the data to IS from all side including the AE? but the AE should be sucessfull...

    if any problem in the AR cache will not trun the SXI_Cache sucessfully......so i suggest run the CPA cache completely...make sure all the activiation is done, check the INTEGREATION_DIRECTORY_HMI (checkl the name) destination is properly entered....then try to rerun thec cache from the IR and ID and check the error if any....

    Regards,

    Suraj Kumar

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      1. The RFC destination is working and correct.

      2. we did a complete CPACache refresh and it went through fine.

      3. I checked the document, but the settings are the same as in dev and no change.

  • avatar image
    Former Member
    Mar 19, 2008 at 02:25 PM

    Hello,

    in this pdf is troubleshooting guide (chapter 4):

    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/1a69ea11-0d01-0010-fa80-b47a79301290

    Hope it helps.

    Regards

    Patrick

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 28, 2008 at 02:24 PM

    There was a clustering setup issue that BASIS fixed.

    Add comment
    10|10000 characters needed characters exceeded