Skip to Content
avatar image
Former Member

Audit trail file

Hi,

In my BW system, in a random way, from sqlplus I get the messages below:

sqlplus "/as sysdba"

SQL*Plus: Release 9.2.0.8.0 - Production on Tue Mar 18 11:35:31 2008

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

ERROR:

ORA-09925: Unable to create audit trail file

HPUX-ia64 Error: 13: Permission denied

Additional information: 9925

ORA-01075: you are currently logged on

Enter user-name:

Then, I try again and I can enter without problems:

sqlplus "/as sysdba"

SQL*Plus: Release 9.2.0.8.0 - Production on Tue Mar 18 11:36:25 2008

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

Connected to:

Oracle9i Enterprise Edition Release 9.2.0.8.0 - 64bit Production

With the Partitioning option

JServer Release 9.2.0.8.0 - Production

Similar situations occur when the database is doing the backup or when it's booting.

Somebody can help me?

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Mar 18, 2008 at 06:28 PM

    Hello Maximino,

    please check the parameter "audit_file_dest" in the pfile / spfile.

    Check if the specified directory exists or if you have write permissions.

    For a detailed step-by-step guide... take a look at here:

    http://laurentschneider.com/wordpress/2007/12/how-to-resolve-ora-09925.html

    Regards

    Stefan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 18, 2008 at 05:34 PM

    Hi

    This is a security issue. You need to check with you UNIX security team. This is related e-trust policy. This policy has to be executed on your ora<sid>

    Cheers

    Shaji

    Edited by: Shaji Jacob on Mar 18, 2008 6:36 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 19, 2008 at 01:15 PM

    Thanks all for your help but specially to Stefan Köhler, your link has helped me a lot.

    The directory rdbms/audit had some files whose owner was root and when the database user had to overwrite on hadn't permission.

    We solve by changing the owner user from root to database user.

    Best regards

    Add comment
    10|10000 characters needed characters exceeded