Skip to Content
avatar image
Former Member

warning messges in database check

Dear All,

I am getting this error: level:

WARNING, type: CRITICAL_TABLESPACE, object: PSAPSR3, value: (max_extn of 5 files on disk 8) 40960000 KB (> 16605280 KB),

I have tried to move to other drive which have enough, but still getting the same error.

Please suggest me what steps to be taken to remove this warning messages for other tablespaces.

Is this going to make any harm in future.

Please suggest me,.

Thanks

Bhaskar

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 18, 2008 at 10:17 AM

    HI,

    CRITICAL_TABLESPACE Warning

    Enhances the CRITICAL_FILE check if there are several autoextend files of a tablespace on the same disk (that is, logical volume) by checking whether there is sufficient free space on the hard disk to extend these files to the maximum size (max_extn).

    CRITICAL_FILE Warning

    Examines the data files with an activated autoextend feature. A check is made to see whether the file system might overflow due to the existing parameter setting (MAXSIZE and INCRSIZE) during the automatic file extension.

    check Note 849484 - New CRITICAL_TABLESPACE check condition in BRCONNECT

    regards,

    kaushal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 18, 2008 at 10:09 AM

    Hi

    Bhaskar,

    Following are the probable solutions for the problem faced by you. Datafiles of tablespace PSAPSR3 are set as autoextendable, if they all grow to their max_size, this will bust available disk space.

    --> solution 1: change max_size for datafiles

    --> solution 2: move all datafiles elsewhere

    --> solution 3: add disk space

    --> solution 4: unset autoextendable.

    Regards,

    Suhas

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Suhas,

      Thanks for your response.

      If I make the tablespace autoextend off, then everytime I need to manually add the datafiles.

      Is there any other option to resixe the autoextent so that it does not overflow the file system.

      Please suggest me.

      Thanks

      Bhaskar

  • avatar image
    Former Member
    Mar 18, 2008 at 11:48 AM

    Hi,

    You need to stop SAP before executing anything on the database.

    STOP SAP

    Login as orasid

    sqlplus "/ as sysdba"

    ALTER DATABASE DATAFILE 'F:\oradata\live\Mydb02.ora' autoextend off;

    commit;

    exit

    START SAP

    Replace 'F:\oradata\live\Mydb02.ora' with the path for all the datafiles of tablespace PSAPSR3.

    If the problem is resolved then do reward points

    Regards,

    sreddy.

    Add comment
    10|10000 characters needed characters exceeded