Skip to Content
0

Listbox reading Dimension issue (DS_Bex)

Dec 04, 2017 at 10:57 PM

54

avatar image

Hi Folks,

Below is the output of a bexquery populating data on Crosstab and Listbox. However i see a difference with certain Dimensions displaying data different than one another.

I checked Query 'edit initial view" all dimension are set to read data from "Only Values with posted data", tried other settings to but still no luck where it is reading from for Listbox_2 Country.

Any suggestion would be highly appreciated.

Please see below screenshot.

Regards,

Fahad

lb.png (131.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Mustafa Bensan Dec 05, 2017 at 09:58 AM
0

Mohd,

The “Only Values with posted data" is only relevant for cascading filter scenarios. What exactly is it that you are expecting to see in your example? If the issue is only the display of Text vs Key then you should apply the script change as suggested by Poovarasan.

Regards,

Mustafa.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Mustafa,

Here is what i want to accomplish. Read first 3x3 rows and columns of crosstab and display it on text as a timeline. Here is what i have so far.

List-box are looking good now, it was hooked with other query that caused the issue.

When i execute the code, it reads nothing and eventually draws nothing on the text (H1,H2,H3,TYPE1....), Not sure what could be wrong with the code as it has worked for me in the past.

Regards,

Fahad

code.png (131.4 kB)
0
avatar image
Former Member Dec 05, 2017 at 06:08 AM
0

Hi,

Can you please explain what exactly is the problem?

Based on my observation, I only find below differences:

1. I, only find that the list box displays the text values as you have given in the script but in crosstab and edit initial view it shows the key values.

You can show the key value in list box by selecting key instead of text in script as below.

DS_1.getMemberList("ZR_STOKY__ZR_CTYK", MemberPresentation.INTERNAL_KEY, MemberDisplay.KEY, 50);

2. The sort order is different in Country listbox, which can be solved by below code.

LISTBOX_1.sort(true);


Please let me know if you have problem with something else.

Thanks,

Poovarasan

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Pooran,

Please see my respond to Mustafa comment.

Regards,

Fahad

0
Mustafa Bensan Dec 06, 2017 at 06:28 AM
0

Hi Mohd,

Some suggestions based on your last comment about "reading the first 3 x 3 rows and columns of crosstab":

1. Firstly, your original question is a general one and you have then followed up with details of your actual problem. In order to get the most effective response from the community you should post your actual issue in the first place;

2. It seems that your requirement is to iterate through the result set of DS_5 and you are trying to achieve this with getMembers(). The values returned from getMembers() are independent of the data source result set and in particular when you have two dimensions as in your case (ZHIREDAT and 0ACTIONTYPE) you will not be able to synchronise columns in corresponding rows with getMembers(). You can only achieve your requirement by applying one of the following approaches:

(a) Use the Design Studio SDK Community Data Iterator Component: https://blogs.sap.com/2016/02/08/design-studio-16-sdk-data-iterator-read-your-data-row-by-row-finally/

(b) Wait until the release of Lumira Designer 2.1 which allows data result set iteration via scripting.

Regards,

Mustafa.

Share
10 |10000 characters needed characters left characters exceeded