Skip to Content

SAP Personas - Copying Flavors

Hi

We are on SAP Personas 3.0 SP3 and I have an issue which is driving me insane.

When copying a Flavor, it works sometimes but for one particular Flavor I want to copy, it won't work. The copy works fine but when you access the Flavor via browser it only has a blue border around it. The main Flavor (the one I copied) is showing as "blue" and all changes I make get assigned to the original Flavor. The copy is existing and shows ok, but it's like it doesn't exist and I can't use it.

Anyone know why this is happening and how to resolve?

Thanks
Shaun

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Oct 20, 2016 at 03:41 AM

    Shaun can you try in IE if using Chrome or vice versa . Don't think this will be useful but just try and give it a shot .

    Add comment
    10|10000 characters needed characters exceeded

    • We are using Chrome as IE11 is just simply too buggy/laggy with Personas.

      However, I just tried IE11 and the exact same issue occured.

      In fact, the whole "copying" of Flavors just seems AWFULLY buggy full stop. I have lost count how many times a "copied version" resets back to the original that I copied from...after hours of me making updates...I have cried countless times (not quite but was close on occasions) and it's becoming extremely frustrating.

      Is anyone else experiencing that?

      This particular issue I can't even get the copy to work, let alone worry about it reverting back.

      I was hoping Personas 3.0 SP3 would not have issues like this...this is a huge issue as copying flavors is something I do all the time.

      Any ideas or feedback?

      Regards

      Shaun

  • Oct 20, 2016 at 04:53 AM

    If you have a reproducible example where such behavior can be observed, by all means open an incident since we'd like to look at the use case to see what's wrong. Copying a flavor should go without any issue.

    I hope your system is fully up-to-date, with all notes properly implemented... Health Check, Notes Checker shows all green for all notes, correct?

    Add comment
    10|10000 characters needed characters exceeded

    • Thank you again Tamas - you are a gentleman and a scholar!

      I can confirm all our notes are showing as green and we are still having this issue.

      Will see what SAP have to say via my OSS incident.

      Cheers
      Shaun

  • Oct 25, 2016 at 06:16 AM

    Hi Shaun,

    We had recently the same Problem.
    Check in your Target System the Transaction Screen Number (in the Status Bar > Dynpro)
    If there is a different Number (e.g. because of modifications) than in your Source System you get this impacts.
    This is correct behavior.

    Regards

    Thomas

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Thomas

      We haven't moved any Flavors to a target system yet. This is all being performed in the Source system and this is where we are getting these issues.

      Regards
      Shaun

  • Oct 27, 2016 at 11:09 AM

    Any luck yet Shaun with this issue ? This is definitely frustrating !

    Add comment
    10|10000 characters needed characters exceeded